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1  INTRODUCTION

About this Booklet
2D Design V2 can be used without reference to a printed manual.  Most functions are self-explanatory

and Help is always available.  However, to achieve the best results in the shortest time, it is recom-

mended that you carefully work through the 2D Design V2 tutorials in this booklet.  The tutorials are

intended as a practical guide to using the software on a day to day basis, not as a deep technical refer-

ence.  For technical reference information use the Help facilities within the software.  

Printing this booklet

This booklet is primarily intended to be used as a printed reference, and has been formatted as such.

Users wishing to follow the tutorials “heads up” on screen are advised to follow the tutorials from the

Help facilities within the software.

Software Overview
In general there are two types of data for drawing packages, bitmap data (typically used in paint type

packages) and vector data (typically used in engineering or architectural draughting packages).

Paint packages colour in the "dots" on screen to form an image.  They are great for simple drawings, or

editing scanned or photographic images.

Vector drawing packages store the drawing as a series of objects, eg., lines, rectangles, circles, etc.

Only the relevant coordinates are stored, so that when the image is reproduced (either on screen or on a

print-out) it can be to a set size, or accurately scaled without loss of definition.  

2D Design V2 is a powerful and sophisticated hybrid drawing package which allows vector drawings

to be created, and bitmap images to be loaded and incorporated into designs.  2D Design V2 covers

many key areas of graphic design, but is also excellent for technical draughting and design.  For those

wishing to run CAD/CAM systems, 2D Design V2 has its own integrated drivers for output devices

such as Roland CAMM 1, STIKA, MODELA, RotoCAMM, etc.  It is also the perfect complement to

laser cutters, print and cut systems, etc.

Educational Use
2D Design V2 is easily capable of professional work, but because of its ease of use it is also widely

used in education.  In fact 2D Design is the standard CAD software for the vast majority of UK sec-

ondary schools.  It is ideal for use at Key Stage 3 up to degree level.  It covers the Graphic Design,

CAD and CAD/CAM elements of the syllabus, and it is used as a tool for all graphic elements in pro-

ject work.  Whenever a sophisticated package such as this is used in education, however, there is

always the risk that younger students may find it daunting.  2D Design V2 deals with this problem by

allowing the user to easily customise the software, and save the simplified setup as a named file.  In

this way several different setups can be saved with facilities to suit different age/ability groups, or dif-

ferent topics.
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2  SYSTEM REQUIREMENTS

1. 2D Design V2 will run on any Windows system using Windows 2000, XP, 2003 or Vista.

(Version 2.00 will also run on Windows 98 if Internet Explorer V5 or later is installed, or on

Windows ME, though future upgrades of the software are unlikely to run on these systems.)

Although the software should run on the minimum specification computer for any particular oper-

ating system, large drawings, particularly those with large or numerous bitmaps, may benefit from

a higher specification machine to improve speed.

2. 2D Design V2 requires a minimum screen display of 800 x 600, though a screen resolution of

1024 x 768 or greater is strongly recommended.  To change the screen resolution, from Windows

you normally choose Start > Control Panel > Display > Settings.

3  INSTALLATION

2D Design V2 is a licensed product and must only be used on computers for which a licence is held.

The software may be supplied on a CD or it may be downloaded.  A separate licence file (.lic) is also

required.  This may be supplied either on a CD, a floppy disk or it may be emailed to you.  The licence

file will be required when the software is first run (if the licence file is not available the software can

only be run in Demo mode).  Keep your licence file safe, as it may be required for future upgrades.  

If installing from a CD, on insertion of the CD into the drive the installation program will normally

auto-start.  If for any reason the installation disk fails to start automatically, choose Start > Run, then

type d:\setup (adapt this as appropriate if using a CD ROM drive other than d) and press ENTER on

the keyboard.  

If you are installing 2D Design V2 for the first time, choose New Installation.  If you are updating an

existing copy of 2D Design V2, choose Update Installation.  By choosing Update Installation you will

avoid having to license your software again as the existing licence file will not be overwritten. 

Follow screen prompts through to completion of installation.  Immediately after installation, run the

software (choose Start > All Programs > TechSoft Design Tools > 2D Design V2, or use the desktop

shortcut icon), and follow the prompts to install your licence file.

Licence upgrades (eg., for new device extensions, or from single user to site), may often be done by

simply installing a new licence file (obtainable directly from TechSoft).  To install a new licence file,

choose Help > Software Licence then click on Update Licence.
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4  SPECIAL FEATURES

Text and Fonts
2D Design V2 has some very powerful text facilities.  It is possible to draw text at any size and orien-

tation, and each individual character within a word or phrase can have its own settings.  Thus letters

can be drawn back to front, upside down, and at any size if desired.  Text can even be made to flow

along complex profiles - not just curves, but any shape or combination of shapes.  

Most drawing packages support coloured text but 2D Design V2 also allows each font (or each charac-

ter) to have a different coloured outline using lines of any thickness, even dotted or dashed lines.  The

fill colour does not just have to be a single colour either, any fill pattern (no matter how complicated),

or even bitmaps can be used.  Although text parameters such as colour and outline style can be set “on

the fly”, it is often useful to pre-set a font so that it can be used again and again  This is easy to do in

2D Design V2 as it incorporates a special “Font Design” mode.  In this mode any existing font may be

loaded and modified.  Not just colours and fills though, even the shape of individual characters may be

modified to create your own custom font.  In fact you can draw up a whole font of your own if you

wish.  Fonts created this way can be saved as a TechSoft font, and then used within 2D Design V2 as

any other font.

Also supplied in the TechSoft font format are a range of single line (or “stick”) fonts ideal for use in

engraved or laser cut designs, etc.

Bitmaps and Vectorisation
Bitmap images can be used in 2D Design V2 in a number of ways.  Images can simply be loaded

directly as drawing elements and then accurately scaled to size if required.  A typical use might be to

add a photograph or scanned image to an item of packaging.  

2D Design V2 also has sophisticated clipping routines which allow bitmap images to have an outline

drawn to “cut out” or  “mask” parts of the image.  Thus, for example, the image of a person could be

cut out of a group photograph then re-scaled and used as part of another image.  Another example

might be to automatically trim a photograph to fit on the panel of a box.

Bitmap images may be converted to vector images.  Normally bitmaps do not scale well, particularly

when making them bigger, as the pixels start to become visible.  By converting the bitmap to a vector

equivalent this problem may be avoided.  Bitmap to vector conversion works best on simple images,

such as clipart with a limited number of colours, or monochrome scans (it does not normally work well

for photographs).  2D Design V2 can also trace or contour around bitmaps to create either graphic

effects or sophisticated cutting paths. 

Although not intended as a bitmap editing program, 2D Design V2 has many functions to control the

appearance of the bitmap.  For example, a bitmap’s colours may be reduced, its resolution may be

reduced, or it can be changed to monochrome or greyscale, etc.

By combining bitmap and vector graphics, incredibly sophisticated images can be created with ease.

One word of caution when using bitmap graphics is to remember your output device.  2D Design V2

can output to many more devices than just printers, but not all devices (eg., milling systems) can output

bitmaps.
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Fills and Patterns
Fills are generated in three ways - when objects such as rectangles, circles, double lines, closed beziers,

etc., are drawn; when “flood filling” pre-drawn boundaries; or when drawing text.  2D Design V2 can

fill objects with simple hatch or solid fills, or with graduated, texture, or pattern fills.  

Graduated Fills  
These can be just simple blends from one colour to another.  However, by defining numerous options

and settings, very sophisticated complex graduations can be created.

Examples of Graduated Fills

Texture Fills
Texture fills are created from bitmap images, such as simple bitmap drawings, photographs or scans.

Texture fills are normally used to create a background effect within a fill.  One bitmap may be used

across the whole fill, or the bitmap may be repeated in a number of ways.  With a suitable bitmap, by

flipping it left/right and top/bottom, a continuous seamless texture can be created to simulate wood

grain, fabrics, stones, etc.  A wide range of suitable bitmaps are supplied with the software for this pur-

pose.

Examples of Texture Fills

Pattern Fills
Pattern fills provide a comprehensive way of using virtually any drawing as a fill.  Images can be vec-

tor or bitmap (or a combination).  There are exhaustive ways of configuring the pattern to create stun-

ning fill images.

Examples of Pattern Fills                   
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5  OUTPUTTING

Output from Windows software is normally done using special Windows printer drivers, either supplied

with Windows, or by the device manufacturer, through a File > Print option.  Whilst this works fine for

may output devices, it often does not allow the software enough control over the output when driving

many CNC machines such as cutting/engraving/milling/plotting type devices.  2D Design V2 therefore

offers two options, the standard File > Print for output via Windows drivers (see Printers / Laser
Cutters / Print and Cut Systems below), and the additional File > CNC Output for output via

TechSoft’s own built-in CNC device drivers (see Knife Cutting / Engraving / Milling / Plotting
Devices below).  Where a TechSoft CNC device driver is available, you are strongly recommended to

output via File > CNC Output.

Further comprehensive details regarding output to individual machines, and how to get the best out of

them, are detailed in the Inset Packs included with most CNC machines supplied by TechSoft.

Printers / Laser Cutters / Print and Cut Systems
When outputting to a printer such as a laser, inkjet, etc., or a laser cutter such as a TechSoft

LaserCAM, or a print and cut machine such as a Roland VersaCAMM, set the Windows printer driver

up in the normal way and use File > Print.  

It is good practice to first set the screen drawing area to match the print device to be used. 

To do this choose the Layout icon from the upper icon toolbar (or Setup > Drawing > Layout).
Choose Match current printer, in the Layout dialog box.  If you do not match to the print device, out-

put can still take place, but you may find that the drawing does not come out where expected on the

media, or the drawing may be tiled across several sheets.

Changes to device settings must be made in the printer driver itself.  These settings may be accessed by

choosing File > Print Setup, or File > Print, and then Properties.  If necessary, fine adjustments to the

position of the drawing on the media, and to the line thickness printed, can be made using File > Print
Options.

If you wish to retain your chosen layout for future sessions, choose Setup > Set As Default or Setup >
Save Setup.

Knife Cutting / Engraving / Milling / Plotting Devices
2D Design V2 uses its own built-in drivers for many CAMM 1, STIKA, MODELA, RotoCAMM, plot-

ters, etc.,  If your output device is listed (see Setup > CNC Devices), use File > CNC Output rather

than File > Print.  The result is an enhanced output quality, and the ability to make use of many special

machine features, such as controlling cutting modes, depths of cut, feed rates, etc., where appropriate.

Additionally, output settings are saved with the drawing file.  (N.B.  Users can still use standard

Windows device drivers by using File > Print if preferred.)

Although it is possible to set the appropriate output device from the CNC Output dialog box 

itself, it is good practice to always begin work by choosing the Layout icon from the upper icon

toolbar (or Setup > Drawing > Layout) to select the appropriate output device and match the media

size, etc., to it.  If you wish to retain your chosen layout for future sessions, choose Setup > Set As
Default or Setup > Save Setup.

Further details of using the built-in drivers are in the TechSoft Inset Packs supplied with machines.
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6  2D DESIGN V2 HELP

Help is a standard Windows feature.  Help gives you easy access to detailed information on every

menu item, tool, dialog box, button and feature in 2D Design V2.  

You can access Help in the following ways:

1. Choose Help > Help Contents.

2. Click on the Help button in a dialog box for help on that dialog box.

3. With any menu item highlighted, press the F1 key to see a Help window describing that menu

item.

4. Choose What’s This? from the upper icon toolbar or Help > What’s This or press

Shift + F1 to display the Help cursor.  Then click on any tool to see a Help window describ-

ing it.
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7  TUTORIALS

TUTORIAL 1 - Screen Layout, Menu Selection, etc.
The 2D Design V2 program window provides a clear view of the current drawing, various information

areas, and a selection of icons with tools to cover the most common drawing, editing, and display func-

tions.

1. Start up 2D Design V2 (Start > All Programs > TechSoft Design Tools > 2D Design V2 or use the

desktop shortcut icon) and familiarise yourself with the screen layout as shown below.

2. Menu items are normally chosen from the menu bar or the toolbox, using the mouse (although

many keyboard alternatives are available).  To choose an item from the toolbox, position the

pointer over the appropriate icon and click the LH mouse button.  Some items in the RH toolbox

(the Drawing Aids toolbox), such as Grid, will cause the icon to stay selected (on) until it is

switched off by clicking on it again.  

3. Many of the items in the LH toolbox (the Draw/Edit toolbox) have pull out toolbars.  These are

activated by positioning the pointer on the icon then pressing and holding the LH mouse button

for a short while.  The pointer can then be dragged along the icon bar until the required icon is

highlighted, then the mouse button released.  This selects the item, and changes the icon in the

toolbox to that chosen.

4. Most menu items, eg., text, grid, etc., have a related dialog box for settings.  To access these dia-

log boxes, double click on the appropriate icon with the LH mouse button, or click on the icon

with the RH mouse button.
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Absolute coordinates show

the position of the cursor rela-

tive to the drawing origin (the

bottom LH corner of the draw-

ing area)

Relative coordinates show

the position of the cursor

relative to the last point

located, or object drawn

(can be reset by pressing

SPACE bar)

Relocatable Drawing Aids

toolbox has a range of

commonly used functions

Coodinate data entry boxes

allow accurate positioning

and drawing at any time

Allows named drawing

layers to be created and

assigned

Simple prompts always

tell you what to do next

Toolbar help explains

each icon

Relocatable Draw/Edit

toolbox allows easy

access to all the main

draw/edit functions

Pull out toolbar.  Just

select a toolbox icon,

and hold down the LH

mouse button to open

the toolbar

Distance shows the

distance from the last

point located or drawn

Angle shows the angle

from the last point 

located or drawn

The white drawing area

represents the size of the

media being used, helping

to match design to output

Allows the setting of line type

(solid, dotted, etc), thickness

and colour

Re-sizeable help

message to keep track

of the current operation

Allows the setting of fill

parameters, eg., fill type,

colour, etc.

Upper Icon Toolbar with

shortcuts to popular

menu items



TUTORIAL 2 - Setting Up the Software to Suit your System
During the course of this tutorial you will set the software to suit your normal requirements.  You will

then save these values as the default.

1. Start up 2D Design V2.  Choose the Layout icon from the upper icon toolbar (or Setup>
Drawing > Layout).  The default setting is for A3 paper.  Most people will normally set the

drawing screen to match the printer/plotter/cutter/miller they are using.  If you have an A4 printer

you may wonder why you would change from the standard A4 paper size.  In fact most printers

cannot print to the edges of the paper, so if you set to match your printer, a grey dotted rectangle

will appear, showing the actual printing area.  If you stay within this rectangle, you should not

“lose” any image when printing.  (This feature depends on the correct values being set in the

Windows printer driver, which is obviously out of TechSoft’s control!)  Use the dialog box to

select the printer/CNC device/material size you will be using most often, then click OK to close.

2. You may wish to investigate some of the options under Setup > Drawing or Setup > Customise.

Any of the options set may be saved as default values in the next step.  At this stage however, it is

probably better to leave these options, and to come back to them after working through the other

tutorials.  (Tutorial 25 deals with setups further.)

3. Choose Setup > Set As Default. Click OK on the warning dialog box.  Close down the software

completely, then restart it.  You will see that it starts up with the Drawing Layout settings you

have made.  (Any other settings made from the Setup menu, eg., the type of grid, will also have

been saved.)

N.B.  If you ever wish to return to the factory default settings, choose Help > Restore Factory Defaults,

then Setup > Set As Default.
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TUTORIAL 3 - Basic Drawing, ie., lines, circles, arcs, curves, etc.

1. Choose the Single Lines icon (LH toolbox).

Move the cursor around, over the white area.  (N.B.  You can draw over the blue area, but it

will not be printed or output.)  Notice the changing coordinates at the bottom of the screen.

Move the cursor to a position where you wish to start a line, and click the LH mouse button.  A

moving line should now appear.  To “finish” a line click the LH mouse button again.  Carry on

drawing a few more lines.  (To help with this tutorial, ensure that some of them crossover each

other.)

2. Choose the Connected Lines icon from the Lines toolbar (LH toolbox, click and hold

on the Lines icon).  Move the cursor to a start point, and click the LH mouse button.  To

“fix” a line section, click the LH mouse button again.  A new moving line should now

appear from the end of the fixed line.  To “finish”, either double click the LH mouse button (this

will “fix” the moving line), or click the RH mouse button (this will finish at the last fixed line).

Try drawing a few lines finished in different ways.  You will notice that although a grid is show-

ing, the lines are not starting and ending on grid positions.

3. Choose the Grid Lock icon (RH toolbox).

Now draw a few more lines.  The ends of the lines will now be fixed to grid positions.

4. Choose the Step Lock icon (RH toolbox).

Now draw a few more lines.  Again the ends of the lines appear to be free.  However, they 

are not entirely free as will be seen after the next two steps.

5. Choose the Zoom in icon (LH toolbox).

Note the prompt reading Locate one corner of zoom box.  Move the cursor approx. 1 grid

square (10mm) below and to the left of any “corner” that you have drawn, then click the

LH mouse button.  The prompt will change to Locate opposite corner of zoom box.  Move the

mouse to pull out a box up to the right, about 30mm square (three grid squares), then click the LH

mouse button.  That area will now be redrawn to fill the screen. 

6. Choose the Connected Lines icon again (LH toolbox).

Draw some more lines.  Notice that when the mouse moves, the cursor moves in small

steps between the grid dots.  In fact the default step spacing is 1mm.

7. Choose the Step Lock icon again (RH toolbox).

This time step lock will be deselected and the cursor will be free to move to any position.

Thus, there are three lock options, grid lock, step lock, and no lock.

8. Choose the Zoom Last icon (RH toolbox).

This will restore the previous zoom level, in this case the full drawing screen.  (You might

also like to try the effects of the Zoom+ and Zoom- icons in the RH toolbox at this point.)

9. Choose the Radial Lock icon (RH toolbox).

As you continue to draw connected lines you will find that any line drawn is now con-

strained to 45 deg steps.  Double click on this icon with the LH mouse button and a dialog

box will appear.  This allows the start angle and step angle to be set.  Try the effects of different

settings.  Many other icons have dialog boxes accessed in the same way.  Alternatively, dialog

boxes may be accessed by clicking with the RH mouse button.  Try clicking on the Grid icon with

the RH mouse button.
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10. Choose the Single Lines icon again from the Lines toolbar (LH toolbox, click and hold

on the Lines icon).  Draw a few lines.

11. Choose the Attach icon (RH toolbox) and ensure that Grid Lock and Radial Lock are off.

The cursor will change to a small square.  Position the cursor square to overlap the end of

any line, and click the LH mouse button.  The start of the line being drawn will automati-

cally start exactly from the end of the selected line.  Position the cursor over the end of a different

line, and click the LH mouse button again.  You do not have to be absolutely accurate in your

positioning, as long as the square is over the line.  It is possible to change the size of the attach

target box or the type of points being attached to, from the attach dialog box (double click on the

icon).  Try setting attach to intersections as well as end points, and try drawing lines between

intersections.  Remember, just make sure that the intersection is inside the attach target box.  

12. So far you have only drawn lines.  Try some of the other drawing functions - circles, arcs, shapes

and paths.  Follow prompts, and use Help for further explanation.

13. Try deleting and undoing as described below.

Simple mistakes may be undone by clicking on the Undo Last icon in the RH toolbox.

This undoes the last operation, either drawing, transforming or deleting.

Once undone, the icon becomes Redo Last.  Clicking on this effectively undoes the undo.

Redo Last is cleared by any further drawing or deleting operation.  

Also in the RH toolbox is Delete Last.
This deletes back one object each time it is chosen.  (Undo Last restores a deleted object,

but only the last one deleted!)

Most other delete functions are in the LH toolbox accessed from the Delete toolbar (click and

hold on the Delete icon):

Delete Any allows you to point to an object and delete it. 

Delete Part deletes any part of a line, arc, circle or bezier curve back to the closest intersection

points from the locating point.

Delete by Box allows you to draw a simple rectangular box that will delete any items inside or

crossing it.

Delete by Lasso allows you to draw a complex shape that will delete any items inside or crossing

it.

Delete by Clip Path deletes any items inside or crossing a clip path (see Tutorial 12 for more

information about clip paths).

Pressing Delete on the keyboard deletes the current selection (see Tutorial 4 for more information

about selection).

Pressing  ALT + Delete on the keyboard deletes the whole of the current drawing.  
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TUTORIAL 4 - Object Selection and the Marquee Box
As you will see in this tutorial, selection is carried out using normal Windows methods.  Selected

objects may be dragged, rotated, flipped, resized or copied quickly and easily.

1. Start up 2D Design V2, or close any open drawings (File > Close).  Choose the Open icon   

from the upper icon toolbar (or File > Open), and load the drawing “Car.dtd” from the

Tutorials directory.  For the purposes of this tutorial only, choose Help > Restore Factory
Defaults.

2. Choose the Select icon (LH toolbox).

Move the cursor below, and to the LH side of the car.  Press the LH mouse button, drag a

box around the drawing, then release (alternatively Select All using the keyboard shortcut

Ctrl + A or the Select All icon from the upper icon toolbar).  The car will be highlighted in pink,

and surrounded by a dotted box (a marquee box) with handles (yellow shapes). 

3. Familiarise yourself with the marquee box functions, as described below.

The large centre square handle allows the box to be re-positioned.  Clicking once on the handle

with the LH mouse button allows the box to be moved around (Grid Lock and Attach still oper-

ate).  A second click with the LH mouse button “drops” the box in its new position (or click the

RH mouse button to cancel the operation.)

N.B.  If the initial click is done with the RH mouse button, the handle will move and not the box.

Subsequent operations such as flip and rotate will act about this handle.  When the marquee box is

de-selected, the centre handle will revert to its normal position.

The corner and edge square handles allow the box to be re-sized.  Clicking with the LH mouse

button allows the handle to move, clicking again redraws the object/s at the new size. 

N.B.  Warning - moving the corner and edge handles can alter the aspect ratio.  In this case, arcs

and circles (in this case the wheels) are converted to elliptical bezier curves, which can no longer

have tangency properties, etc.  Clicking in a corner handle with the RH mouse button, then mov-

ing, maintains the aspect ratio, keeping circles and arcs fixed.  

The circular handle to the right of the marquee box allows the object(s) to be rotated.  

N.B.  This can be used in conjunction with the Radial Lock tool (RH toolbox).
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The diamond handles, above and to the left of the box, flip the object(s) vertically or horizontally,

and the double handle below the box copies the object(s), leaving the new copy selected.  

Experiment with these handles to test the effects.  

N.B.  To undo a transformation (or any other drawing or editing operation), click on the Undo
Last icon in the RH toolbox.

4. An individual object (single line, arc, etc.) can be selected by moving the pointer near it and click-

ing the LH mouse button.  Clicking on another object in the same way will select the new object

(de-selecting the first object).  Clicking on an object with the RH mouse button (or SHIFT + LH

mouse button) will "add" or "remove" the object from the selection by toggling its select state.

Multiple objects can be selected by dragging a select box around them with the LH mouse button.

Dragging another select box in the same way will create a new selection (cancelling the first).

Dragging a select box with the RH mouse button (or SHIFT + LH mouse button), will toggle the

select state of the objects.

To de-select objects, move the pointer outside the marquee box and click the LH mouse button.

Individual objects may be de-selected using the RH mouse button (or SHIFT + LH mouse button)

as described above.  

Try all of the above options on the car to get the feel of the selection process.
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TUTORIAL 5 - Editing the Drawing
Selected objects may be easily edited (start/end/centre/nodes of lines/arcs/paths/text, etc., moved and

modified).

1. Start up 2D Design V2, or close any open drawings (File > Close).  Choose the Open icon  

from the upper icon toolbar (or File > Open), and load the drawing “Sammy.dtd” from the

Tutorials directory.  For the purposes of this tutorial only, choose Help > Restore Factory
Defaults. 

Dynamic Editing

2. Choose the Select icon (LH toolbox).

Select the lower straight line forming Sammy’s tail.  You will notice the Property
/Start Edit toolbox open in the bottom RH corner of the screen. 

Click on the Start Edit button.

The line will turn grey, and a red and green circle will appear at the ends.  These are the nodes of

the line (defining points), green indicates the start point, red the end point.  Click on the red node

using the LH mouse button.  The node will now follow the mouse freely around.  Click again and

the line will be repositioned at that point.  Click on Undo Last (RH toolbox) to return the line to

its original position.  Now click on the red node again but using the RH mouse button.  The line

will still move, but is now constrained along its own path (so it can only get longer or shorter).

Click again to place the line, then click on Undo Last to return the line to its original state.  To

remove the nodes, click “off” (away from) the drawing, (or click on End Edit).  This will return

the marquee box.  Click off again to de-select.  

3. Now select Sammy’s stomach curve by clicking near it, then click on Start Edit.

The curve will grey, and circles will appear on it to denote the nodes.  (In this case these points

are the original location points when the curve was drawn, green - start, red - end, and orange for

all other defining points).  Each node has two yellow handles (only one for the start and end

points).  Clicking on a node or a handle with the LH button allows that point to be moved around.

Clicking on one of a pair of handles with the RH button, locks the angle of the handles and allows

them to move together.  Try a few of these options then click off to de-select. 
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4. Now select Sammy’s back curve and then click on Start Edit.  You may have noticed

that as Start Edit is selected, it is replaced by a longer option menu (so far with all

the options greyed out).  To activate these options, a node or line/curve section must

be selected.   

Move the cursor near to the centre section of Sammy’s back and click the LH button.

This section will turn pink, indicating that it is selected. 

Click on the Add Node button in the Edit Mode toolbox.  An extra node will appear on the select-

ed curve.  Click on this node with the LH mouse button and drag the node upwards.  Click again

to drop the node.  Move the node and its handles until it looks something like the illustration

below then click off the drawing to de-select it.  You have now given Sammy a fin! 

5. By now Sammy may  be a bit of a mess.  If so, close your drawing (File > Close) then 

choose the Open icon from the upper icon toolbar (or File > Open), and load the drawing

“Sammy2.dtd” from the Tutorials directory.  

6. Choose the Select All icon from the upper icon toolbar (or Edit > Select > All, or press 

CTRL+A on the keyboard) to select the whole drawing.  Click on Start Edit (in the bottom

RH corner). 
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Drag a select box over Sammy’s tail as shown below.

It is now possible to move the whole tail section.  Click on one of the selected (pink) nodes and

move the mouse until Sammy looks something like the illustration below, then click off the draw-

ing to de-select it.  In this way, very powerful editing changes can be made very easily.

So far you have adjusted bezier curves, but all other drawing objects (circles, arcs, text, etc.) have

nodes as well and many have control points.  When selecting nodes or line/curve/arc sections the nor-

mal select rules apply.  You can select multiple items by dragging a select box over them, and using the

RH mouse button you can add or remove items from the selection.

Editing Object Properties

It is often important to be able to look at and maybe alter the properties of an object.  Some properties

such as layer, line type and fill, can be changed via the attributes bar at the top of the screen (see

Tutorial 7).  However, full control of an object’s properties is available via the Property button.

7. Click the LH mouse button near to Sammy’s eye to select it.  Choose Property from the

Property/Start Edit toolbox to open the Circle Properties dialog box.

.

As you will see very comprehensive details of the circle are displayed.  The values and settings

may be edited if required.  You might like to try altering the value of the radius or assigning a fill.

Changing properties this way only works for individual objects.  If more than one object is selected the

Property button will be greyed out.
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TUTORIAL 6 - Transformations
You have already tried simple transformations using the marquee box in Tutorial 4.  There are different

transformation functions available in the LH toolbox, Move/Copy, Mirror Image, Rotate, Distort, etc.

All these functions operate in a similar way.  First you must select the objects to be transformed using

the Select option.  Then choose the appropriate transform option (the objects will stay selected but the

select box will disappear).  Set/check the variables in the dialog box that appears, then follow the

screen instructions.  The following example illustrates their use.

a                                                b                                               c                     

1. Start up 2D Design V2, or close any open drawings (File > Close).  Choose the Open icon  

from the upper icon toolbar (or File > Open), and load the drawing “Flower.dtd” from the

Tutorials directory.  (See fig a.)  For the purposes of this tutorial only, choose Help > Restore
Factory Defaults.  

2. Choose the Select icon (LH toolbox).

Select the leaf only, by clicking next to it, or by dragging a select box over it.

3. Choose the Mirror image icon (LH toolbox, click and hold on the Transform icon).

Ensure that Repeat/Replace is set to Repeat.  Ensure that Grid Lock is on.  At the prompt

Locate one point on axis of reflection, move the cursor to co-ordinate position 

Abs (200, 160), then click the LH mouse button.  At the second prompt Locate another point on
axis of reflection, locate the cursor at co-ordinate position Abs (200, 100).   The drawing should

appear as in fig b.

You will now repeat and rotate the petal around the circle.  As the centre of the circle is not on a grid

position we will need to set the software to automatically attach to its centre.

4. Choose the Select icon (LH toolbox).

Select the petal only, by clicking next to it, or by dragging a select box over it.

5. Ensure that Grid Lock is off, then click on the Attach icon (RH toolbox) with the RH

mouse button (or double click with the LH button) to open the Attach Settings dialog box.
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6. Select Centre of arc/circle then click OK to close the dialog box.

7. With the Attach icon still highlighted, choose the Rotate icon (LH toolbox, click and hold 

the Transform icon).  Ensure that Angle of rotation is set to 60 deg, Repeat/Replace to

Repeat, No. repeats to 5, then click OK.  At the prompt Locate centre of rotation, move the

cursor (now a square) over any part of the circle and click the LH mouse button.  Click off to de-

select.  The finished drawing should now appear as in fig c.

It is good practice not to leave attach items set when you are not using them, as this can cause confu-

sion if you are locating and attach to the wrong thing.  Click on the Attach icon again with the RH

mouse button and untick Centre of arc/circle.
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TUTORIAL 7 - Line Styles and Line Colours
This tutorial will deal with drawing and changing line styles and colours.

a                                               b                                               c                     

So far, all the drawing done (if you are following these tutorials closely!) will be in solid black lines.

To set a different line style or colour, new parameters are set from the attributes bar at the top of the

screen. 

If the line and colour settings are changed to, say, dashed with colour red, all subsequent lines will be

red dashed lines.  Existing lines may easily have their parameters changed as shown below.

1. Start up 2D Design V2, or close any open drawings (File > Close).  Choose the Open icon  

from the upper icon toolbar (or File > Open), and load the drawing “Bracket.dtd” from the

Tutorials directory.  For the purposes of this tutorial only, choose Help > Restore Factory
Defaults.  

This drawing uses solid fine lines (the default setting).  For visual reasons it is sometimes desirable to

use thicker lines, eg., in this case it would be better if the main lines of the bracket were thicker than

the centre lines to be drawn later.

2. Choose the Select All icon from the upper icon toolbar (or Edit > Select > All or press 

CTRL+A on the keyboard).  See fig a.  You will notice that the Line... and Col... windows

on the attributes bar are now blank (indicating that the settings may be changed). 

3. Click on the Line button on the attributes bar at the top of the screen. 

The Line Style Settings dialog box will open.

Select Thick and set the thickness to 0.75mm.  Click OK.  Click off the drawing to de-select it.

You will see that all lines have been redrawn much thicker.

You may have noticed that some of the lines should be hidden detail lines (short dashes).  You will

now select these lines and change their settings and colour.
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4. Ensure that the Select icon (LH toolbox) is chosen.

Select any one of the hidden detail lines (see the pink lines in fig b if unsure) by clicking on

it with the LH mouse button in the normal way.  Change to the RH mouse button and select

the rest of the lines one at a time.  Each will be “added” to the selection.  (If a wrong line is

selected by mistake, click on it again with the RH mouse button to remove it from the selection.)

5. With all the hidden detail lines selected, click on the Line button on the attributes bar again to

open the Line Style Settings dialog box.  Set Type to a short dash, Pitch to 6mm and Width to

Fine, then click OK.

6. With the lines still selected, click on the Col button next to the Line button.                      

The Line Colour dialog box will open.

Choose the blue colour in the Custom colors section, then click OK.  Click in a clear space to de-

select the lines.  

Whilst it is easy to change the line style and colour retrospectively, it is usually more sensible to use

the correct settings in the first place.  You will now draw some centre lines on the drawing.

7. Click on the Line button on the attributes bar at the top of the screen to open the Line Style
Settings dialog box.  Set Type to a long dash and a dot, Pitch 15mm, Width to Fine.  Set the colour

to Custom color red by clicking on the Col button next to the Line button.

8. Choose the Single Lines icon (LH toolbox), and ensure that Grid and Grid Lock (RH

toolbox) are on.  Draw in the centre lines as shown in fig c.

When creating or changing a line style you may have noticed that the first linetype in the list is

Invisible, and you may have wondered what use an invisible line is.  When drawing an object such as a

filled rectangle, by default it will be drawn with a black line surrounding it. If this black line is not

required, it may be set to invisible instead.  (N.B.  Invisible lines can have their on-screen appearance

changed using the menu Setup > Customise > Redraw Settings - useful if you have forgotten they are

there!)
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TUTORIAL 8 - Using Fills
2D Design V2 has very powerful fill capabilities.  Objects may be filled with simple hatch or solid

fills, or with graduated, texture or pattern fills.  This tutorial will show how to draw filled objects, and

how to fill areas of existing drawings.  For details on creating new fills see Tutorial 9.

Any closed object, eg., rectangle, circle, polygon, closed bezier, etc., can be given a fill as it is drawn.

The current fill type is shown on the attributes bar at the top of the screen. 

If the fill settings are changed to say, solid red, all new closed objects will be filled in solid red.  

1. Start up 2D Design V2, or close any open drawings (File > Close).  Choose the New icon  

from the upper icon toolbar (or File > New).  For the purposes of this tutorial only, choose

Help > Restore Factory Defaults.  

2. Choose the Horizontal Rectangle icon (LH toolbox).

3. Follow the screen prompts to draw a couple of random rectangles.  You will see lines only

with no fill (ie., you will be able to see the grid through the rectangle).

4. Click on the Fill button on the attributes bar at the top of the screen. The Fill Settings
dialog box will open.

Select Solid and set the Colour to Custom Color Red.  Click OK to close the dialog box.  Draw

some more rectangles and note the red fill with a black border.  Draw some more closed objects,

eg., circles, in different colours.

Drawing filled objects in this way is useful, but often you will have created an outline from a variety of

lines, arcs, curves, etc., and you then wish to fill inside it.  
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5. Close your current drawing (File > Close).  Choose the Open icon from the upper icon  

toolbar (or File > Open), and load the drawing “Cottage.dtd” from the Tutorials directory.

Note that a few of the more “fiddly” parts of the drawing have already been filled.

6. Choose the Boundary Fill icon (LH toolbox).

From the Boundary Fill settings dialog box, click on the Fill button to open the Fill Settings dia-

log box.  Click on the Load Fill button and load the fill “Tiles” from the Fills directory.  Note the

settings in the Fill Settings dialog box then click OK to close all dialog boxes.  At the prompt

Locate one edge of boundary on side for fill, locate at approximately point 1 shown above.  To the

question Any islands, answer No.  The roof will fill with the tile texture at the size specified.   

Double click with the LH button (or click with the RH button) on the Boundary Fill icon to bring

back the dialog box.  Click on the Fill button to open the Fill Settings dialog box.  Click on the

Load Fill button and load the fill “Bricks” from the Fills directory.  Note the settings in the Fill
Settings dialog box then click OK to close all dialog boxes.  At the prompt Locate one edge of
boundary on side for fill, locate at approximately point 2 shown above.  To the question Any
islands, answer Yes and locate at point 3, repeat for points 4 and 5, then answer No.  The walls

and chimney will fill, leaving holes for the windows and door.  Note that an island can be internal

or external, external islands are filled, internal ones are not.  

Repeat the procedure above to fill with “Grass” at point 6 and “Sky” at point 7.  (N.B. When fill-

ing the sky you could treat the “sun” as an island and not fill it, but as the sun will be fully filled

later there is no need in this case.)

When the sky was filled you will have noticed that the sun was obscured.  This is because parts of the

sky outline were drawn after the sun, so the sky fill is also drawn after the sun, ie., “on top” of it.  It is

however easy to correct as explained below.

7. Choose the Select icon (LH toolbox).

Move the cursor over the sky fill and click the LH mouse button to select the fill.  The 

whole fill should be cross hatched in pink.  

Choose the To Back icon from the upper icon toolbar.

The drawing data will be re-ordered so that the sky is now drawn first.
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8. To finish the drawing, proceed as in step 6 to fill the sun with the fill “Sun”, the door with fill

“Door” (don’t forget to select the knob and letterbox as islands), and the curtains with fill

“Curtains”.  Your drawing should now appear as below.

Changing fills once drawn is a very similar process to changing line types and fills (see Tutorial 7).

You select the fill or fills you wish to change, then click on the Fill button on the attributes bar at the

top of the screen to set the replacement fill.
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TUTORIAL 9 - Creating New Fills
2D Design V2 has a very sophisticated and powerful facility to use and create a variety of fill types

from simple hatch or solid fills, to graduated, texture or pattern fills.  These fills can be used when

objects are drawn, as in-fills for pre-drawn boundaries and for filling text.  The full range of possibili-

ties is way beyond the scope of this booklet.  A selection of fills is supplied with the software, but it is

easy to create new fills and to save them for future use.

In Tutorial 8 you used some fills that had already been created.  In this tutorial you will create and

save some fills of your own.

a                                                                          b                        

Creating a Graduated Fill

1. Start up 2D Design V2, or close any open drawings (File > Close).  Choose the Open icon  

from the upper icon toolbar (or File > Open), and load the drawing “Shapes.dtd” from the

Tutorials directory.  (See fig a.)  For the purposes of this tutorial only, choose Help > Restore
Factory Defaults.  

2. Click on the Fill button on the attributes bar. 

The Fill Settings dialog box will open.  Select Graduated.

26

Software Tutorials forSoftware Tutorials for
2D Design V22D Design V2



You will see a square sample window showing the current fill, and a rectangular colour bar that is

used to set the fill colour parameters.  Under the colour bar at each end is a small paint can which

determines the colour at its position on the bar.  Move the cursor over the black can, then click

and hold the LH mouse button and drag the can backwards and forwards whilst observing the

effect.  You will notice that in the Position box a reading is given of the position of the can along

the bar.  Now drop the black can and try the same thing with the white can (the cans can be

crossed over each other).  Notice that the active can has a red pointer on top.

3. Move the cans back to their start points.  Click on the LH can to make it active, then click on the

Colour... button, to open the Fill Colour dialog box.  Select Red from the Custom colors selection,

then click OK to close.  In the same way, change the colour of the RH can to black.

4. Click on the Add Colour button.  This will open the Fill Colour dialog box.  Select White from

the Basic colors selection, then click OK to close.  A new can will appear on the colour bar.  Slide

this can to position 30 (alternatively you can enter this value in the Position text entry box and

choose Apply).  Add another can, colour red, at position 55. 

5. Select Fixed Size and change the value in the X Size text entry box to 8mm, then click on the

Apply button to activate the setting.  The Fill Settings dialog box should now appear as below.

6. Click on Save Fill and save the fill with the file name “Red Tubes”.

7. Try changing a few other variables to see the effect.  In particular try rotating the fill by clicking

on the dial in the Rotation section and spinning the dial around (or type in a value and Apply).

Creating a Pattern Fill

8. Select Pattern.  Click on the Load Pattern button and load the image “Duck.wmf” from the

Patterns directory.  

Load Pattern allows any graphics file that 2D Design V2 can load to be used as the basis of a pattern

fill. 
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9. The sample window represents a rectangle 40mm wide.  This should give you an idea of scaling

in the final drawing.  In this case the window is a little small to get the full effect of the pattern.

Change the Sample Width setting to 80mm then choose Apply to get a better view.

10. In the Tessellation Settings section, change the Offset value to 12mm, the X Gap to 4mm then

click Apply. (The total repeat spacing for the ducks is 24mm - an X size of 20mm + an X Gap of

4mm.  To get an even overlap, an Offset of half this, 12mm, has been set). 

11. Select Flip X.  This flips alternate images in the X axis.

If the fill is used as it is, the background (the space between the ducks) will be transparent, and any

other drawing underneath will show through.  You may like to try this later.  In this case we will set a

coloured background colour.

12. Untick Transparent.  Click on the Background Colour... button to open the Fill Colour dialog box.

Select the pale yellow from the Basic colors selection, then click OK to close.  The  Fill Settings
dialog box should now appear as below.

13. Click on Save Fill and save the fill with the file name “ducks”.

Creating a Texture Fill

14. Select Texture.  Click on the Load Texture button and load the bitmap “Shiny Metal Weave.jpg”.

from the Textures > Weave directory.  

Load Texture allows any bitmap file that 2D Design V2 can load to be used as the basis of a texture

fill.  In this case the texture is one of the library of textures supplied with the software.

15. Select No. Rows/Columns, and set the No. Columns to 3, then click Apply.  The  Fill Settings dia-

log box should now appear as below.
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16. Click Save Fill and save the fill with the file name “Mesh”, then choose Cancel to exit the dialog

box.

Having created some fill patterns you can now use them.

17. Choose the Boundary Fill icon (LH toolbox).

From the Boundary Fill Settings dialog box, click the Fill button to open the Fill Settings
dialog box.  Click on the Load Fill button and load the fill “Red Tubes” which you saved

earlier.  Click OK to close all dialog boxes.  At the prompt Locate one edge of boundary on side
for fill, locate the inside edge of the curved shape.  To the question Any islands, answer No and

the shape will fill.  Double click with LH button (or click with the RH button) on the Boundary
Fill icon to bring back the dialog box.  Load the fill “Ducks” and fill the hexagon with it.  Repeat

the procedure to fill the lozenge with the fill “Mesh”.  The drawing should now appear as in fig b.

You may have noticed that Texture fills only use bitmaps, whilst Pattern fills use any drawing (which

could include a bitmap).  On the face of it Texture fill is not really necessary.  In fact whilst Pattern
fills provides very powerful options, they are optimised for use with vectors and mixed drawings.

Texture fills are optimised for use with bitmaps, so that when images are repeated they can form per-

fectly tessellated seamless fills.

Fills can be used with a variety of drawing operations; drawing new closed objects (where the fill is set

on the attributes bar), using boundary fill (where the fill is set in the Boundary Fill Settings dialog

box), and text, (where the fill is set in the Text Settings dialog box).  Each of these operations has its

own settings, ie., changing a fill for text will not affect the settings for new closed objects.  If you wish

to quickly match one of the other fills (without saving and re-loading), the Fill Settings dialog box has

buttons at the bottom to allow this. 

Warning - A pattern fill is very powerful and can be used to create stunning graphical effects.  Any

drawing file can be used, in particular 2D Design files, and WMF vector files (commonly used for cli-

part) can be ideal.  However, when a large drawing is used as the “pattern”, which is then repeated

multiple times, drawing sizes can become very large, resulting in potentially slow redraw times and

possible computer memory problems.  
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TUTORIAL 10 - Text
The text functions are very comprehensive.  Text fonts may be in Windows Outline or TechSoft Font

format (see Tutorial 11 for more details of TechSoft Fonts).  There are three basic text functions,

Linear text by variable which allows the user to set all variables, font, sizes, spacings, colours, etc;

Linear text by box which allows the user to pre-define font, colour, etc., then to apply the text to a user

defined box; and Text along a path which allows text to flow around the outside or inside of a selected

path object (normally a circle, arc, polygon or bezier curve).

1. Start up 2D Design V2, or close any open drawings (File > Close).  Choose the New icon  

from the upper icon toolbar (or File > New).  For the purposes of this tutorial only, choose

Help > Restore Factory Defaults.  

2. Choose the Linear text icon (LH toolbox).  Ensure that Grid Lock (RH toolbox) is on.  

At the prompt Locate start position for text, move the cursor to position Abs (120, 200)

approx., then click the LH mouse button.  The following dialog box will open.

Type in TechSoft<Return>for<Return>CAD/CAM then click the Settings button.  The follow-

ing dialog box will open.

Ensure that the font is set to Arial Black (if not available choose another font), and Height to 25.

Click OK on both dialog boxes.   Your text should appear as below.
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3. Choose the Select icon (LH toolbox).

Move the cursor over the text and click the LH mouse button to select it.  Notice the

Property/Start Edit toolbox open in the bottom RH corner of the screen.

Click on the Property button.  The Text Entry dialog box will open.  Click on the

Settings button to open the Text Settings dialog box.  

Set Alignment to Centered then click on the Col... button next to Fill... and change the colour to

Custom color green.  Tick Add drop shadow and change the X and Y values to 15.  Click on the

Spacing button to open the Text Spacing dialog box

Set the Line Spacing to 80, then click OK to close all dialog boxes.  Your text should appear as

below.
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N.B.  Obviously all the settings in steps 2 and 3 could have been made at one time, but one of the

objectives of this tutorial is to show how text can be changed in different ways.

4. With the text still selected, click on the Property button again to open the Text Entry dialog box as

shown below.

Highlight the words “CAD/CAM” (drag the text cursor over the characters so that they are high-

lighted in blue).  Click on the Settings button to open the Text Settings dialog box.  Change the

Height value to 30, then click on the Fill... button to open the Fill Settings dialog box.

Select Graduated, then click on the Colour... button and set the colour to Custom color red.  Click

OK to close all dialog boxes, then click off to de-select.  Your text should appear as below.
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The above example has shown how to edit the properties of selected characters within a text phrase.

Below is an alternative option for doing the same thing.

5. Select the text again, but this time click on the Start Edit button in the bottom RH corner of the

screen.  Each text character will be drawn with a yellow handle (it is possible to move each char-

acter by dragging the handle).  You may now sub-select text characters.  Use the LH mouse button

to click on the letter T.  Use the RH mouse button to click on the letters e c h in turn to select

them (do not click on the handles).  

With the letters selected click on the Adjust button in the Edit Mode toolbox in the bottom RH

corner of the screen.  The Text Settings dialog box will open.  Change the Fill... colour to light

grey and click OK to close all dialog boxes.  The word “Tech” will turn grey.  With the text still

selected click away from the text to undo the sub-selection.  Now sub-select the letters S o f  t and

set them to custom colour blue.  Finally click away from the text a few times to completely de-

select it.  Your text should appear as below.

6. This example demonstrates just some of the powerful text facilities available.  Close the current

drawing (File > Close), then open the drawing “TextDemo.dtd” and observe some of the many

other possible text effects. 
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The “textdemo” file raises an important point regarding the transfer of files which use either Windows

Outline fonts or TechSoft Fonts.  When using any font, as drawings are created, edited, re-drawn, etc.,

the software refers back to the font data stored in the computer.  If a drawing is saved and then loaded

onto another computer, the text can only be reproduced correctly if the fonts used are installed on the

second computer.  If the fonts are not found, the text cannot be reproduced as the original.  The

“textdemo” file contains a variety of fonts unlikely to be found on your computer.  To be able to dis-

play them correctly, the text was first selected, then “exploded” using Edit > Explode.  This converts

the text to a series of individual letter “shapes” (paths).  Although the text properties are lost, the shape

of each letter can now be modified using Start Edit, a useful feature in its own right.  (N.B.  Redrawing

exploded text can be much slower than redrawing normal text, so text should only be exploded when

really necessary.)

TechSoft fonts can only be used within 2D Design V2.  When any drawing containing TechSoft fonts

is transferred to another software package, via cut and paste for example, the text will be transferred as

individual letter shapes.

34

Software Tutorials forSoftware Tutorials for
2D Design V22D Design V2



TUTORIAL 11 - TechSoft Fonts 
2D Design V2 comes with a range of TechSoft fonts.  Most of these are single line fonts, primarily

designed for use with engraving machines, laser cutters, etc.  It is possible to create your own TechSoft

font from scratch though this can be quite tedious.  For most users a more suitable starting point would

be to load an existing font (Outline or TechSoft), and alter the characters as required.  This can then be

saved as a TechSoft font.  (Please note that copyright restrictions must be observed.)

This tutorial demonstrates how a standard font may easily be altered and saved as a TechSoft font.

a                                                b                                               c                     

d                                                e                                               f                    

1. Start up 2D Design V2, or close any open drawings (File > Close).  Choose the Open Font
icon from the upper icon toolbar (or File > Open Font), and load the outline font Arial with

Font Style Regular.  (See fig a.)  

2. Choose the Zoom in icon (LH toolbox).

Zoom in around the capital letter ‘R’ as shown in fig b.  

3. Choose the Select icon (LH toolbox).

Move the cursor over any part of the letter ‘R’ and click the LH mouse button to select it.

Click on the top diamond handle to flip the letter left to right.  With “R” still selected click

on the Property button (in the bottom RH corner of the screen) to open the Single Line Path
Properties dialog box.  Click on the Fill Col button and select the blue colour in the Custom col-
ors selection.  Click OK to close all dialog boxes, then click in a clear space to de-select.  The let-

ter ‘R’ will now be mirrored and blue.

4. Choose the Zoom Last icon (RH toolbox).

You will now select a rarely used character and replace it with a pre-drawn symbol.

5. Choose the Zoom in icon (LH toolbox).

Zoom in on the character ‘^’ (ascii code 94) as shown in fig c.
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6. Choose the Delete Any icon (LH toolbox).

Move the cursor over the ‘^’ character and click to delete it.

7. Choose the Add icon from the upper icon toolbar (or File > Add) and load the drawing  

“NoSmoke.dtd” from the Tutorials directory.  Use the handles on the marquee box to adjust

the size and position of the symbol (use the RH mouse button when moving the corner handles to

ensure that the aspect ratio does not change) until it is roughly as shown in fig d, then click off the

symbol to de-select it.

You will now need to adjust the width of the character cell to ensure suitable spacing of the symbol

when it becomes a text character.

8. Choose the Select/Edit Character Design Frame(s) icon (LH toolbox, click and hold on

Select).  Move the cursor over the Character Design Frame with the symbol in and click the

LH mouse button to select the frame.  (See fig e.)

9. With the Character Design Frame highlighted, choose Cell from the Frame/Cell tool-

box (now showing in the bottom RH corner of the screen).

10. Ensure that Dynamic cell width adjustment is selected then click OK.  All frames will

have a vertical red line showing the cell width, and a circular yellow handle (in the selected frame

the handle will be pink).  Click on the pink handle and adjust the cell width so that it extends

slightly to the right of the symbol (do not hold down the mouse button).  (See fig f.).  Click the

LH mouse button to fix the cell width, then choose the End button in the bottom RH corner of the

screen.

Choose the Select icon (LH toolbox, click and hold on Select) to exit the Font Grid Edit
Mode (or Edit > Font Grid Edit Mode).

The font must now be saved before it can be used.

11. Choose the Save Font icon from the upper icon toolbar (or File > Save As TechSoft Font).  
Enter the name “Tutorial” and click OK to save the font.

12. Close the current drawing (File > Close), then choose the New icon from the upper icon  

toolbar (or File > New) to start a new drawing.

13. Choose the Linear text icon (LH toolbox).

At the prompt Locate start position for text, move the cursor to a position Abs (160, 140),

approx., then click the LH mouse button.  The following dialog box will open.

Type in We R ^ then click the Settings button.  
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The following dialog box will open.

Select TechSoft Font then select “Tutorial” from the list.  Click OK on both dialog boxes. 

Your text should appear as below.

Using the same basic procedure as above, any font can easily be modified to suit your specific require-

ments.
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TUTORIAL 12 - Loading a Bitmap Image and Clipping It
Clip paths are invaluable tools for graphic design work.  They are user defined closed shapes which

can be used to delete or hide parts of a drawing.  The following example illustrates a common applica-

tion.

As part of a design, the image of an apple is required.  The only apple image available is of an apple in

a bowl of fruit, so it is necessary to "extract" the image of the individual apple from the rest of the

fruit.  

a                                                b                                                c                                            

1. Start up 2D Design V2, or close any open drawings (File > Close).  Choose the New icon  

from the upper icon toolbar (or File > New).  For the purposes of this tutorial only, choose

Help > Restore Factory Defaults.  Ensure that Grid Lock and Step Lock (RH toolbox) are off.

2. Choose the Import Bitmap icon from the upper icon toolbar (or Bitmaps > Import Bitmap)   

and load the image “Fruit.jpg” from the Tutorials directory.  (See fig a.)  The Bitmap Image
Size and Colour dialog box will open.  Click OK to accept the default values.

To work more accurately it will be helpful to zoom in to the apple.

3. Choose the Zoom in icon (LH toolbox).

Zoom in around the apple as shown in fig b.

4. Choose the Draw a Clip Path icon (LH toolbox).

Note that the Closed Path Segment toolbox has opened in the bottom RH corner of the

drawing area.

5. Choose the Close Curve icon from the Closed Path Segment toolbox.

Move the cursor to any position on the edge of the apple and click the

LH mouse button.  Move the cursor about 15mm (see Distance at the

bottom of the screen) along the edge of the apple (either direction) and

click again.  This will draw the first section of the clip path around the apple.  Continue to move

the cursor around the apple clicking about every 15mm.  When the cursor is about 15mm from the

start point click the RH mouse button to close the clip path (you could close the clip path with a

double click of the LH mouse button but this will put in an extra unnecessary point).  The clip

path will be drawn as a thin grey line.

The clip path drawn will probably be a close, but not exact fit to the apple.  It is difficult to get a good

fit when drawing around a shape as the curve may not always bend as required.  The next step shows

how to adjust the clip path to be an exact fit.

38

Software Tutorials forSoftware Tutorials for
2D Design V22D Design V2



6. Choose the Select icon (LH toolbox).

Move the cursor to point to the clip path and click the LH mouse button to select the path.

7. With the clip path highlighted, choose Start Edit from the Property/Start Edit toolbox

(now showing in the bottom RH corner of the screen).

Move the nodes and the handles to get the best possible fit of the path to the apple.

You may also need to add nodes for small detail.  (See Tutorial 5 for more details of

editing.)  When you are happy with the fit of the clip path, move the cursor away from the clip

path and click to leave edit mode (or click on End Edit in the bottom RH corner of the screen). 

8. Choose the Clip to a clip path icon (LH toolbox, click and hold on the Clip icon).

Move the cursor to point to the clip path and click the LH mouse button to select the path.

The Clip Settings dialog box will open as below.

Ensure that Mask - Hide excess data and Clip outside are selected, then click OK.  The excess

data will be made invisible, leaving just the image of the apple (see fig c).

Either masking or trimming would have given the same visual effect.  In this case masking was chosen

as it may be useful to leave the original image available, to allow you to re-edit the clip path at a later

time.  (To re-edit the the clip path, simply select it, then choose Start Edit from the Property/Start Edit
toolbox.)

Although the example above clips a photograph, clipping works with any image.  Clip paths are (by

default) drawn in a fine grey line.  By default they are always drawn on top of the rest of the drawing.

They cannot be printed or output to CNC devices and so will not “spoil” your output.  If you do not

wish to see clip paths on screen, they can be made invisible by choosing Setup > Customise > Redraw
Settings.  
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TUTORIAL 13 - Clipping an Image to Fit a Shape 
This tutorial demonstrates another common use of clip paths (see also Tutorial 12).  When creating a

net for a card box, a photograph is to be placed on the main panel.  As the photograph is rectangular, it

must be trimmed to fit.

a                                                b                                               c                     

1. Start up 2D Design V2, or close any open drawings (File > Close).  Choose the Open icon  

from the upper icon toolbar (or File > Open), and load the drawing “GorillaBox.dtd” from

the Tutorials directory.  (See fig a.)  For the purposes of this tutorial only, choose Help > Restore
Factory Defaults.

2. Choose the Import Bitmap icon from the upper icon toolbar (or Bitmaps > Import Bitmap)   

and load the image “Gorilla.jpg” from the Tutorials directory.  (See fig b.)  The Bitmap
Image Size and Colour dialog box will open.  Click OK to accept the default values.

You will see that the photograph obscures the box which will make accurate positioning difficult.

3. With the photograph still selected, choose the To Back icon from the upper icon toolbar

(or Edit > Arrange > Put to Back), to rearrange the drawing order so that the box is drawn

over the photograph.  

4. Choose the Select icon (LH toolbox).

Move the cursor to point to any line of the box and click the LH mouse button to select the

box.  Click on the centre handle of the marquee box then move the box to centre the main

panel over the gorilla.  Click again to “drop” the box (initially the image of the box will stay fixed

while the marquee box moves, on the second click the drawing will be updated).  It may take a

few goes to get the positioning just right.  Finally, move the cursor to a clear part of the drawing

area and click again to de-select the box.

5. Choose the Create a clip path by locating a boundary icon (LH toolbox, click and hold. 
on the Clip Path icon).  At the prompt Locate a closed boundary for the clip path, move

the cursor to a position inside the main panel, close to an edge, then click the LH button.

At the prompt Any islands? answer No.  A clip path will be created around the central panel of the

box.  The clip box will automatically be selected (when de-selected it will be seen as a grey line).  

6. With the clip path still selected, add the photograph to the selection by clicking on it with the RH

mouse button.  
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7. With both items selected, choose the Clip selected object(s) to clip path(s) icon (LH 

toolbox, click and hold on the Clip icon).  The following dialog box will open.

Ensure that Trim -Delete excess data and Clip outside are selected, then click OK.  The excess

data will be deleted, leaving the panel filled with the photograph (see fig c).

Either masking or trimming would have given the same visual effect.  In this case trimming was cho-

sen as deleting the excess photographic data would make for a smaller file size when saved.  (N.B.

Not all “excess” bitmap data can be deleted as bitmaps are always stored as rectangles.  The bitmap

will be reduced to the smallest possible rectangle.)

Although the example above clips a photograph, clipping works with any image.  Clip paths are (by

default) drawn in a fine grey line.  By default they are always drawn on top of the rest of the drawing.

They cannot be printed or output to CNC devices and so will not “spoil” your output.  However if you

do not wish to see them on screen they can be made invisible by choosing Setup > Customise >
Redraw Settings.  
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TUTORIAL 14 - Bitmap to Vector Conversion 
Bitmaps are great for many reasons, but because the image is effectively made from coloured dots,

they do not lend themselves to outputting to most CNC machines for cutting purposes.  These opera-

tions normally require a vector line for the cutter head to follow.  In addition bitmap images do not

scale up well - if you start with a small image and enlarge it, the dots quickly become obvious and can

spoil the effect.  For these reasons 2D Design V2 has a built in bitmap to vector converter.  The soft-

ware can isolate different colours in an image and “trace” around them to produce a vector equivalent

of the bitmap.  However, whilst bitmap to vector conversion can produce great results, care should be

taken with the source image.  Conversion works best with relatively simple images with a few colours.

A photograph, for example may have literally millions of colours in it and each patch of colour can be

very complex.  To make the mathematics of conversion realistic on a desktop PC, firstly the number of

colours has to be reduced to a realistic level.  This is done automatically in the software, though some

manual input can be used to help the software “see” the required image correctly.  The complexity of

large bitmaps is also controlled automatically by effectively lowering the resolution of the image to a

manageable size (this can be overwritten if you wish to have a more accurate result and are patient!).

Despite these reservations bitmap to vector conversion can be an invaluable tool for allowing machin-

ing of hand drawn images (when scanned), bitmap clip art, pre-printed images (eg., existing school

logos), etc.

a     

b                                              c                     
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1. Start up 2D Design V2, or close any open drawings (File > Close).  Choose the New icon  

from the upper icon toolbar (or File > New).  For the purposes of this tutorial only, choose

Help > Restore Factory Defaults.  

2. Choose the Import Bitmap icon from the upper icon toolbar (or Bitmaps > Import
Bitmap).  Load the image “ManualCover.jpg” from the Tutorials directory  (see fig a.)  The

Bitmap Image Size and Colour dialog box will open.  Click OK to accept the default values.  

The source material for this tutorial is an old workshop manual cover which has been scanned.  The

objective is to create a vector image that could be used to cut out one of the logos on a CNC machine.  

3. Choose the Zoom All icon (RH toolbox).

4. Choose the Clip to a box icon (LH toolbox, click and hold on the Clip icon).

Ensure that Grid Lock and Step Lock (RH toolbox) are both off.  Refer to fig a, then follow

the screen prompts and draw the clip box from position 1 to position 2 (if you wish, you

may zoom in further first).

The following dialog box will open.

Ensure that Trim -Delete excess data and Clip outside are selected, then click OK.  The excess

data will be deleted, leaving only the logo (see fig b). 

5. Choose the Zoom All icon (RH toolbox).

6. Choose the Vectorise icon (LH toolbox). 
At the prompt Locate the bitmap for vectorisation, locate the bitmap.  After a time delay,

the Color Selection for Vectorisation dialog box will open.
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You will notice that although at a glance the bitmap appears to be just two colours it actually contains

around 20,000 different colours.  These will be mainly different shades of yellow and grey.  The soft-

ware has already reduced these to a more manageable number of colours by grouping together colours

that are similar.  However, as we just want a simple cutting path, we can do better by manually setting

to monochrome to have just two colours.

7. Select Monochrome.  The image will turn to black and white only.   You will notice that there is

some “noise” on the image (black speckles).  These may well be removed automatically during

the conversion process, but to help out, move the Luminance slider from side to side.  As you

move the slider to the right, more of the image becomes black and the noise increases, as you

move it to the left more of the image turns white and the noise reduces but the image starts to dis-

appear.  In this case a good compromise value is around 100, so set the value to this and click OK
to continue.  The Bitmap Vectorisation Settings dialog box will open.

The default Conversion Settings have been found to give the best results for most bitmaps, but

you may wish to experiment sometime later.  
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N.B.  The Conversion Resolution section of the dialog box above may or may not be visible

depending on how tightly you have clipped to the logo.  By default the image is reduced to a sen-

sible size for conversion as indicated at the LH end of the slider.  The value at the RH end is the

full resolution of the bitmap.  Increasing the resolution may increase the quality of the conversion

(it will also increase significantly the conversion time), but in a few cases it may also reduce it, as

reducing the resolution can “smooth out” imperfections along edges.  If the section does not

appear this is because the image is already small enough.

Stick with the default values for now and click OK to continue.  After a short pause the image will

be changed to vectors.  If you wish you may now edit the vector image to alter it in some way.

Do this by selecting the image, then choosing Start Edit from the Property/Start Edit toolbox in

the bottom RH corner of the screen. 

Now to try a full colour conversion.  

d                                                                      e                             

8. Close the current drawing (File > Close), then choose the New icon from the upper icon  

toolbar to start a new drawing.

9. Choose the Import Bitmap icon from the upper icon toolbar (or Bitmaps > Import
Bitmap).  Load the image “Penguin.bmp” from the Tutorials directory (see fig d.)  The

Bitmap Image Size and Colour dialog box will open.  Click OK to accept the default values.  

The source material for this tutorial is a small clipart image.  As you can see, the pixelation at this size

is marked.

10. Choose the Vectorise icon (LH toolbox). 
At the prompt Locate the bitmap for vectorisation, locate the bitmap.  The Color Selection
for Vectorisation dialog box will open.
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You will notice there are only 13 colours in the design.  The conversion can easily handle this number

of colours, although if the image was being produced for use in vinyl cutting it would pay to reduce the

number further.  With this image the background colour may be a nuisance, so as we just want the pen-

guin image we will remove the background during conversion.

11. Move the Col Group Tolerance slider from side to side.  As you move the slider to the left, more

colours will be visible, as you move it to the right less colours will be visible.  This is because the

colours are combined in groups, the higher the tolerance the more colours will be combined into

one group.   In this case a good compromise value is 70, so set the value to this. 

12. Untick the Inc. setting for the first colour in the list (a shade of pale blue).  This will stop this

colour from being converted and will leave only six colours in the design.  Click OK to continue.

The Bitmap Vectorisation Settings dialog box will open.  Leave the default settings and click OK
to continue.  The penguin will now be converted to a vector form with the background removed.

The image can be edited by selecting it, then choosing Start Edit from the Property/Start Edit
toolbox in the bottom RH corner of the screen.

The ability to remove the background in this way is very useful.  Often the background to a bitmap of

this type is white.  This can still be removed in the same way, though it is easy to forget to do so!

(N.B.  When removing backgrounds in this way it is possible to inadvertently remove other areas of the

drawing in the same colour.  These end up as “holes” in the drawing.  These will become obvious if the

image is placed over a coloured background.)
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TUTORIAL 15 - Contours
The Contour drawing routine has a number of practical uses.  It can be used to create a cutter diameter

compensated toolpath for machining purposes; it can be used to create interesting graphical effects; or

it can be used to “pick out” the outline of a complicated shape to create a single outline profile.  The

following examples illustrate these uses.

a                                                b                                               c                     

1. Start up 2D Design V2, or close any open drawings (File > Close).  Choose the Open icon  

from the upper icon toolbar (or File > Open), and load the drawing “Heart.dtd” from the

Tutorials directory.  (See fig a.)  For the purposes of this tutorial only, choose Help > Restore
Factory Defaults.  

2. Choose the Contour icon (LH toolbox).  The following dialog box will open.

Ensure that the Contour spacing is set to 10mm, the Max number of contours to 1, and that Tool
path is selected.  Click OK.

3. At the prompt Locate one edge of the boundary on side for contour, move the cursor to position 1

approx., as shown in fig a, then click the LH mouse button.  

4. In order to bring back the Contour settings dialog box, double click with the LH

mouse button (or click with the RH mouse button) on the Contour icon (LH toolbox).

Select Graphical path instead of Tool path, then click OK.

5. At the prompt Locate one edge of the boundary on side for contour, move the cursor to position 2

approx., as shown in fig b, then click the LH mouse button.  The drawing will appear as in fig c.

This example clearly demonstrates the difference between a Tool path and a Graphical path.  A Tool
path produces a radius around sharp corners.  (The path is actually the locus of the centre of a cutting

tool producing the shape, hence the name).  The main purpose of the Tool path contour is to create

toolpaths for subsequent machining using milling type systems (typically MODELAs and

RotoCAMMs, etc.).  If the tool follows the contour produced outside the shape, the shape will be cut

out accurately.  If the tool follows the contour produced inside the shape, a “hole” of the shape will be

cut out.  
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The Graphical path more accurately follows the contour of the shape and is often preferred when pro-

ducing graphical effects.  (It will, however, sometimes lead to exaggerated profiles at corners as illus-

trated above.)  Of course, Tool path can also be used for graphical effects if preferred.

The next example illustrates the use of multiple contours for graphical effects.

d                                               e                                               f                     

6. Close the current drawing (File > Close), then choose the Open icon from the upper icon  

toolbar (or File > Open), and load the drawing “Butterfly.dtd” from the Tutorials directory.

(See fig d.)  

7. Choose the Contour icon (LH toolbox).

Ensure that the Contour spacing is set to 5mm, and the Max number of contours to 20, then

click OK.

8. At the prompt Locate one edge of the boundary on side for contour, move the cursor to position 1

approx., as shown in fig d,  then click the LH mouse button.  The drawing should appear as in fig
e.  Locate again at position 2 approx., as shown in fig d.  The drawing should appear as in fig f.

In this example, the contour shapes will be the same whether Tool path, or Graphical path is used.

The maximum number of contours was set at 20 to ensure that the shape would be fully filled.  If you

wish to fully fill a shape, choose a number slightly larger than you think you will need.

The next example illustrates the use of the Contour function to “extract” a boundary from a complex

shape.

g                                               h                                               i      

9. Close the current drawing (File > Close), then choose the Open icon from the upper icon  

toolbar (or File > Open), and load the drawing “Box.dtd” from the Tutorials directory.  (See

fig g.)  
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10. Change the current line colour to red, by clicking on the Line Col... button on the attributes bar at

the top of the screen, then choosing Custom Color red from the Color dialog which will open.

11. Choose the Contour icon (LH toolbox).

Ensure that the Contour spacing is set to 0mm, and the Max number of contours to 1, then

click OK.

12. At the prompt, Locate one edge of the boundary on side for contour, move the cursor to position

1 approx., as shown in fig g, then click the LH mouse button.  The drawing should now have a red

boundary. 

13. Choose the Select icon (LH toolbox).

Move the cursor to position 2 approx., as shown in fig h, then click the LH mouse button.

The new outline shape should now be selected.  (N.B.  If two objects are drawn over each

other Select will first choose the last drawn, but re-clicking in the same place will progressively

select earlier objects).  Click on the centre handle and move the outline to its new position as

shown in fig i. Click off to de-select.

Apart from the obvious graphical applications, this operation is particularly useful for creating a cutting

path for a CAMM 1 type system which uses a knife blade.  In this case, the black lines can be scored

and the red outline cut (at stage 12).
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TUTORIAL 16 - Double Lines
Double lines are very useful drawing tools.  They have a range of associated parameters which can be

changed to create useful and interesting effects.  Two examples are given below. 

a                                                b                                               c                     

1. Start up 2D Design V2, or close any open drawing (File > Close).  Choose the New icon  

from the upper icon toolbar (or File > New).  For the purposes of this tutorial only, choose

Help > Restore Factory Defaults.  Ensure that Grid and Grid Lock (RH toolbox) are on.

2. Double click with the LH mouse button (or click with the RH mouse button) on 

the Double Path icon.  The following dialog box will open.

Set the Width to 8mm, and the Corner type to Round, then click OK.  Notice the Path Segment
toolbox which will have appeared in the bottom RH corner of the drawing screen.  By default this

will be set to an Open Line path segment.

3. At the prompt Locate start point, move the cursor to co-ordinate position Abs (150, 180), then

click the LH mouse button.  Locate again at position Abs (340, 180).

4. Choose the Open Arc icon from the Path Segment toolbox in the bottom RH corner of

the screen.  Move the cursor to co-ordinate position Abs (340, 110), then locate.

5. Choose the Open Line icon from the Path Segment toolbox in the bottom RH corner of

the screen.  Move the cursor to co-ordinate position Abs (80, 110), then locate.

6. Choose the Open Arc icon from the Path Segment toolbox in the bottom RH corner of

the screen.  Move the cursor to co-ordinate position Abs (80, 170), then locate.
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7. Choose the Open Line icon from the Path Segment toolbox in the bottom RH corner of

the screen.  Move the cursor to co-ordinate position Abs (290, 170), then locate.

8. Choose the Open Arc icon from the Path Segment toolbox in the bottom RH corner of

the screen.  Move the cursor to co-ordinate position Abs (290, 120), then locate.  

9. Choose the Open Line icon from the Path Segment toolbox in the bottom RH corner of

the screen.  Move the cursor to co-ordinate position Abs (150, 120), then either double click

the LH mouse button, or single click the LH mouse button then single click the RH mouse

button, to finish.

The drawing should now appear as in fig a.  Before starting the next drawing you may wish

to save the current drawing using the Save icon on the upper icon toolbar (or File > Save).

10. Press Alt + Delete (Edit > Delete > All) to clear the current drawing.  Ensure that Grid and Grid
Lock are on.

11. Set the fill to Solid, and the colour to Custom Color red, using the Fill... button on the attributes

bar at the top of the screen.

12. Double click with the LH mouse button (or click with the RH mouse button) on 

the Double Path icon (LH toolbox) to open the Double Line Path Properties dialog box.

Set the Width to 20mm, and the Corner type to Round, then click OK.  

13. Choose the Close Line icon from the Path Segment toolbox in the bottom RH corner of

the screen.  Move the cursor to co-ordinate position Abs (80, 40), then locate.  Move the

cursor to co-ordinate position Abs (210, 260), then locate.  Move the cursor to co-ordinate

position Abs (340, 40), then either double click the LH mouse button, or single click the LH

mouse button then single click the RH mouse button, to finish.  (See fig b.)

14. Set the fill colour to black using the Fill Col... button on the attributes bar at the top of the screen.

15. Double click with the LH mouse button (or click with the RH mouse button) on 

the Double Path icon (LH toolbox) to open the Double Line Path Properties dialog box.

Set the Width to 15mm, and the End cap to Triangle - Width 15 - Height 15, then click OK.  

16. Choose the Open Line icon from the Path Segment toolbox in the bottom RH corner of

the screen.  Move the cursor to co-ordinate position Abs (250, 60), then locate.  Move the

cursor to co-ordinate position Abs (250, 130), then locate.  Move the cursor to co-ordinate

position Abs (180, 80), then locate.  Finally move the cursor to co-ordinate position Abs (180,

150), then either double click the LH mouse button, or single click the LH mouse button then sin-

gle click the RH mouse button, to finish.

The drawing should now appear as in fig c.  You may like to try experimenting with other double line

settings.

N.B.  It is possible to convert a single line path to a double line path, and vice versa, by first selecting

the path, then using Edit > Path Conversion > Convert to Double Line Path or Edit > Path Conversion
> Convert to Single Line Path as appropriate.
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TUTORIAL 17 - Construction Points
Construction Points are very important for helping to layout a drawing.  They allow the user to specify

points for location.  For example, construction points may divide a line/arc/curve into a number of

equal parts, or a construction point may be set a fixed distance along a line, etc.  Once a construction

point has been created it may be located using the Attach tool.  Thus lines may be drawn to construc-

tion points, circle centres located at them, lines cut back to them, etc.  It is important to remember that

construction points, although marked on screen by a small grey circle, will not appear on any output

device, and so will not “spoil” a printout.  (Construction Points can have their on-screen colour/size

changed, or can be made invisible using the menu Setup > Customise > Redraw Settings).  The follow-

ing example illustrates a simple application.

a                                                b                                               c                     

1. Start up 2D Design V2, or close any open drawings (File > Close).  Choose the Open icon  

from the upper icon toolbar (or File > Open), and load the drawing “Radio.dtd” from the

Tutorials directory.  (See fig a.)  For the purposes of this tutorial only, choose Help > Restore
Factory Defaults.

2. Choose the Draw Construction Points which divide a given object icon (LH toolbox,

click and hold the Const Points icon).  The following dialog box will open.

Ensure that the Number of divisions is set to 10, then click OK.

3. At the prompt Locate object, move the cursor to co-ordinate position 1 approx., as shown in fig a,

then click the LH mouse button.  Locate again at position 2 approx.  The drawing should appear

as in fig b.

4. Double click with the LH mouse button (or click with the RH mouse button) on the

Attach icon (RH toolbox).  The following dialog box will open.
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Ensure that Construction point is ticked, and that all other Attach entities are not ticked, then click

OK. Ensure that the Attach icon is on.

5. Choose the Single line icon (LH toolbox).

At the prompt Locate start point, move the attach cursor (now a square) over the bottom

left construction point, and click the LH mouse button.  At the Locate end point prompt,

move the attach cursor over the top left construction point, and click the LH mouse button to draw

a line.  

6. Complete the drawing by connecting up the other construction points in a similar way, as shown

in fig c.

N.B.  It is worth noting that apart from printing and plotting, construction points can be treated as any

other drawing object, ie., they can be deleted, moved, copied, repeated, etc.

53

Software Tutorials forSoftware Tutorials for
2D Design V22D Design V2



TUTORIAL 18 - Scaling and Drawing to Scale
It is possible to set the paper/material size to represent very large sizes and work at full size.  Thus you

could effectively be drawing a full size aeroplane on a very large piece of paper.  However if you did

this, your printout may be tiled into hundreds, even thousands of pieces of A3 or A4 paper.  Thus this

practice is not recommended! 

It is more normal to stick to a standard size piece of paper (normally the standard size for your printer

or plotter), and to scale the drawing so as to fit onto the paper.  Paper (media) sizes are set using Setup
> Drawing > Layout (or choosing the Layout icon on the upper icon toolbar).   The drawing scale is set

using Setup > Drawing > Scale.  The Drawing scale dialog box allows the Media (output or printed

size) to World (actual size) ratio to be set.  Thus if a scale of 1:10 is set, a line of actual length 100mm

long will be printed 10mm long.

The following simple drawing of a garage should illustrate the point.

a                                                b                                               c                     

1. Start up 2D Design V2, or close any open drawings (File > Close).  Choose the New icon  

from the upper icon toolbar (or File > New).  For the purposes of this tutorial only, choose

Help > Restore Factory Defaults.  Ensure that Grid and Grid Lock are on (RH toolbox).

2. Choose Setup > Drawing > Scale. The following dialog box will open.

Choose a Preset scale of 1:20, then click OK.

It is possible to work in millimetres (the default unit), but this entails using lots of rather large num-

bers.  It is therefore preferable to change the units to metres at this point.
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3. Choose Setup > Drawing > Units. The following dialog box will open.

Set the Length Units to metres, then click OK.

4. Choose the Connected Lines icon (LH toolbox, click and hold on the Lines icon).

Draw a line from Abs (2.2, 3.4) to (2.2, 0.8) to (6.2, 0.8) to (6.2, 3.4).  (Click the RH mouse

button to finish.)  (See fig a.)

5. Draw a new line from Abs (2, 3.2) to (4.2, 4.8) to (4.2, 5) to (2, 3.4) and back to (2, 3.2).

Draw a new line from Abs (4.2, 4.8) to (6.4, 3.2) to (6.4, 3.4) to (4.2, 5).  (See fig b.)

6. Draw a new line from Abs (2.8, 0.8) to (2.8, 3.2) to (5.6, 3.2) to (5.6, 0.8).  (See fig c.)

7. Choose the Delete Part icon (LH toolbox, click and hold on the Delete icon). 

Finish the drawing by deleting the part lines where the walls intrude into the roof.

You might like to save this drawing and come back to it later after working through Tutorial 20 -
Dimensioning.  You can then add some dimensions and see how the scaling affects the dimension

sizes.
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TUTORIAL 19 - Grouping and Adding
Often groups of objects are more conveniently treated as one object.  As in the example below, it is

much easier to treat a chair as one object, rather than as a lot of individual lines.  A group is formed by

selecting the required objects, then “grouping” them.  A group can be treated as a single object, select-

ed, copied, deleted, etc.  It is also possible for a group to contain sub-groups.

When loading a drawing using File > Open, a new drawing window is opened and various setup para-

meters, eg., paper size, units, etc., are restored.  You may, however, wish to incorporate a pre-drawn

(library) item into your existing drawing.  This is done using the File > Add option.  (File > Add is also

useful for loading a file without affecting the current setup parameters.)

a b c

d e f

1. Start up 2D Design V2, or close any open drawings (File > Close).  Choose the Open icon  

from the upper icon toolbar (or File > Open), and load the drawing “Office.dtd” from the

Tutorials directory.  (See fig a.) 

2. Choose the Semicircular arc, locating end points icon (LH toolbox, click and hold on the

Arcs icon).  Ensure that Grid Lock (RH toolbox) is on.  At the prompt, first locate at Abs
(2.60, 3.80) then at (2.60, 3.20) to fix a semicircle.  (N.B.  The drawing scale is 1:20 and

units have been set to metres.)

3. Choose the Connected Lines icon (LH toolbox, click and hold on the Lines icon).

Draw a line from Abs (2.60, 3.80) to (3.00, 3.80) to (3.00, 3.20) to (2.60, 3.20), to form the

outline of a chair.  Turn on Step Lock (RH toolbox).

4. Choose the Contour parallel to a line, arc/circle or curve icon (LH toolbox, click and 

hold on the Contour icon).  In the Contour Settings dialog box, ensure that the Contour
spacing is set to 0.06m, then click OK.  At the prompt, locate at Abs (2.75, 3.75) approx.,

(2.35, 3.50) approx., then (2.75, 3.25) approx.  This completes the chair (see fig b.)
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5. Choose the Select icon (LH toolbox).

Drag a select box from Abs (2.20, 3.00) approx., to (3.20, 4.00) approx., to select the whole

chair. 

6. Choose the Group icon from the upper icon toolbar (or Edit > Group, or press 

CTRL + G on the keyboard.  In future the whole chair can be selected by clicking near any

of its component parts.

7. Choose the Add icon from the upper icon toolbar (or File > Add) and load the drawing  

“Desk.dtd” from the Tutorials directory.   A desk and chair set will be “added” to the draw-

ing.  (See fig c.)  Note that the added drawing is automatically selected. 

8. Choose the Radial Lock icon (RH toolbox).   Click on the rotate handle of the marquee 

box (the small yellow circle on the RH side of the box), with the LH mouse button.  Rotate

the desk until it matches the orientation in fig d, then click the LH mouse button again.

Note that with Radial Lock on, rotation is constrained to 45 degree increments.  Turn Radial Lock
off.

9. Choose the Select icon (LH toolbox).  Ensure that Step Lock (RH toolbox) is off.

At the prompt Select object(s)/transform/edit, position the cursor near any part of the chair

and click the LH mouse button.  Click on the centre handle of the marquee box with the LH

mouse button.  Turn Grid Lock on.  At the reposition prompt, locate at (2.00, 2.40).  (See fig e.)

10. Choose the Rotate icon (LH toolbox, click and hold on the Transform icon).

In the Rotate Settings dialog box, ensure that Repeat/Replace is set to Repeat, No. repeats is

set to 2 and Angle of rotation is set to 70 degrees, then OK.   Turn off Grid Lock (RH tool-

box).  Double click with the LH mouse button (or single click with the RH mouse button) on the

Attach icon (RH toolbox) to open the Attach Settings dialog box.  Ensure that Centre of arc/circle
is ticked, then click OK.  Ensure that Attach is on, then at the prompt Locate the centre of
rotation, position the attach cursor over the circle (so that the circle cuts the attach target), and

click the LH mouse button to locate.  The drawing should now appear as in fig f.
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TUTORIAL 20 - Dimensioning and layers
2D Design V2 has a range of dimensioning functions sufficient to meet most needs.  For some dimen-

sions, it is important that exact points are located, eg, ends of lines.  In these cases the Attach tool

should be used to ensure accurate location.  For other dimensions, a rough location is all that is

required, eg., locating a circle to dimension its radius.  

Layers are a useful way of keeping discrete parts of a drawing separated.  In concept, layers can loose-

ly be imagined as transparent drawing sheets, each with its own part of the drawing, and which can be

placed over each other, or removed.  A typical use for layers is to put dimensioning on a separate layer,

so that if further work is needed on the drawing, the dimensioning layer may be turned off to remove

the “clutter” of the dimensioning.  In a similar way, if an object is to be cut, machined, or engraved, the

dimensioning/notes/border, etc., may be “turned off” first.

The following example illustrates the use of dimensions, and of putting dimensions onto a separate

layer.  (Whilst dimensioning does not have to go on a separate layer, it may often be useful to do so.)

a b c

d e f

1. Start up 2D Design V2, or close any open drawings (File > Close).  Choose the Open icon  

from the upper icon toolbar (or File > Open), and load the drawing “Dryer.dtd” from the

Tutorials directory.  (See fig a.)  For the purposes of this tutorial only, choose Help > Restore
Factory Defaults.  
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2. Click on the Layer button on the attributes bar at the top of the screen.  The following dialog box

will open.

Note that the current layer is called “Dryer” and is active.  Click on the line “Layer 2”, then click

on the Current tick box to set this layer current.  Choose the Rename button, and rename the layer

“Dimensions”.  Click OK to close both dialog boxes.  Any new drawing will now be on the sec-

ond layer called “Dimensions”.

N.B.  Only one layer can be current.  All layers not current can be made invisible, and/or inactive.

All new drawing will take place on the current layer.  Objects on layers which are not visible will

not be drawn.  Objects on inactive layers cannot be selected, whether visible or not.  There is no

practical limit to the number of layers possible.

3. Double click with the LH mouse button (or click with the RH mouse button on the

current Dim Lines icon (any dimension icon will do, parallel is the default).

The following dialog box will open.

Ensure that Match text and line colours is ticked, then click on the Line Col button and select the

Custom Color Red.  Click OK to close the dialog boxes. 

4. Ensure that Attach (RH toolbox) is on and Grid Lock (RH toolbox) is off.
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5. Choose the Horizontal Dimension icon (LH toolbox, click and hold on the Dim Lines
icon).  Position the attach cursor at position Abs (120, 230) approx., and click the mouse

button to locate.  Position the attach cursor at position Abs (300, 230) approx., and click the

mouse button to locate. Turn on Grid Lock.  Position the cursor at position Abs (200, 250), and

click the mouse button to locate.  The first dimension should now be drawn.  Turn off Grid Lock.

Position the attach cursor at position Abs (120, 230) approx., and click the mouse button to locate.

Position the attach cursor at position Abs (85, 205) approx., and click the mouse button to locate.

Turn on Grid Lock.  Position the cursor at position Abs (100, 250), and click the mouse button to

locate.  The second dimension should now be drawn.  (See fig b.)  Turn off Grid Lock.

6. Choose the Parallel Dimension icon (LH toolbox, click and hold on the Dim Lines icon).

Position the attach cursor at position Abs (85, 185) approx., and click the mouse button to

locate.  Position the attach cursor at position Abs (120, 160) approx., and click the mouse

button to locate. Turn on Step Lock.  Position the cursor at position Abs (90, 155), and click the

mouse button to locate. 

7. Choose the Vertical Dimension icon (LH toolbox, click and hold on the Dim Lines icon).

Position the attach cursor at position Abs (85, 185) approx., and click the mouse button to

locate.  Position the attach cursor at position Abs (85, 205) approx., and click the mouse

button to locate. Turn on Grid Lock.  Position the cursor at position Abs (60, 220), and click the

mouse button to locate.  (See fig c.)  Turn off Grid Lock and Attach.

8. Choose the Angular Dimension icon (LH toolbox, click and hold on the Dim Lines icon). 

Position the cursor at position Abs (290, 155) approx., and click the mouse button to locate.

Position the cursor at position Abs (260, 110) approx., and click the mouse button to locate.

Position the cursor at position Abs (300, 120) approx., and click the mouse button to locate.

(See fig d.)

9. Choose the Radius Dimension icon (LH toolbox, click and hold on the Dim Lines).

Position the cursor at position Abs (305, 220) approx., and click the mouse button to locate.

Position the cursor at position Abs (330, 230) approx., and click the mouse button to locate. 

(See fig e.)

10. Click on the Layer button on the attributes bar at the top of the screen.  In the dialog box select

the layer “dryer” and untick both Visible and Active.  When the dialog box is closed, the main

drawing will disappear, leaving only the dimensions. (See fig f.)  You might try the same thing

again, but making only the dryer visible.

You may now like to start again and try out the other dimensioning options available.  You might also

like to try the effects of changing some of the Dimension Settings.

If a dimension is selected, then Start Edit chosen, it is possible to reposition the dimension

control points.  If Property is chosen, the Dimension Settings dialog box appears allowing

changes to the dimension variables, or say the text content, just on the highlighted dimen-

sion.  The ability to alter text content is very useful if non-standard dimensioning is to be

used.  

N.B.  Whilst every attempt has been made to comply with accepted standards on dimensioning, draw-
ings dimensioned manually must always rely on human interpretation of the “rules”.  It may therefore,
occasionally be necessary to modify computer generated dimensioning to suit individual requirements.

60

Software Tutorials forSoftware Tutorials for
2D Design V22D Design V2



TUTORIAL 21 - 3D Effects and Exploding
As its name implies, 2D Design V2 works with 2D drawing data.  However it does have a range of 3D
Effects which make 2D drawings look 3D.  The 3D Effects functions operate in a similar way to the

general transformation functions.  First you must select the objects to be transformed using the Select
option.  Then choose the appropriate 3D effects option.  The following two examples illustrate their

use.

a                                                b                                               c                     

d                                                e                                               f            

1. Start up 2D Design V2, or close any open drawings (File > Close).  Choose the New icon  

from the upper icon toolbar (or File > New).  For the purposes of this tutorial only, choose

Help > Restore Factory Defaults.  

2. Choose the Horizontal Rectangle icon (LH toolbox) and turn on Grid Lock (RH toolbox).

Draw a rectangle with corners at Abs (20, 20) and (180, 100).

3. Choose the Circle with a given centre and radius icon (LH toolbox, click and hold on

the Circles icon).  Set the circle radius to 30mm, then click OK to close the dialog box.

Locate the centre at coordinates Abs (100, 60).

4. Choose the Closed polyline icon (LH toolbox, click and hold on the Path icon).

Draw a trapezium with corners at Abs (60, 100), (80, 120), (120, 120) and (140, 100).

(Click the RH mouse button to finish).  (See fig a.)

5. Choose the Select icon (LH toolbox).

Select the rectangle by clicking next to it.

6. Choose the Perspective with double vanishing points icon (LH toolbox, click and hold on

the 3D Effects icon).  Set the Finish depth to 60, then click OK to close the dialog box.

Locate the first vanishing point at Abs (10, 190), the second vanishing point at Abs (410,

190) and the reference point at Abs (180, 20).  You should now have a 3D view of the rectangle.

(See fig b.)
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7. Choose the Select icon (LH toolbox).

Select the trapezium so that it is highlighted.

8. Choose the Perspective with double vanishing points icon (LH toolbox).

Set the Start depth to 10, the Finish depth to 60, and ensure that the option Use last refer-
ence points is ticked.  When you OK on this dialog the trapezium will immediately be

transformed to 3D.  (See fig c.)

9. Choose the Select icon (LH toolbox).

Select the circle so that it is highlighted.

10. Choose the Perspective with double vanishing points icon (LH toolbox).

Set the Start depth to 0, the Finish depth to -50, and ensure that the option Use last refer-
ence points is ticked.  When you click OK on this dialog box your basic 3D transformation

will be complete.  (See fig d.)

The three objects have each been transformed into a “3D object”.  As with all objects they can now be

selected and edited, in this case by moving the control points to alter the perspective.  As there are

three objects they should all be selected together to ensure that they keep the same control points.  The

easiest way to do this is to “group” them before editing.  (Grouping was dealt with in more detail in

Tutorial 19.)

11. Choose the Select All icon from the upper icon toolbar (or Edit > Select > All, or press 

CTRL + A on the keyboard).  The whole drawing should now be highlighted.

12. Choose the Group icon from the upper icon toolbar (or Edit > Group, or press 

CTRL + G on the keyboard).    

13. With the whole drawing selected you will notice the Property/Start Edit toolbox in the

bottom RH corner of the screen.  Choose Start Edit.  Three yellow control handles will

be shown.  Click on any of these and move them about to see the effect on the image.

(See fig e.)

You may wish to delete the “hidden lines”.  As 2D Design V2 is not a 3D package, there is no automat-

ic facility for this.  However, for simple drawings it can be achieved fairly easily by using the Delete
Any and Delete Part functions.  Before this can be done, however, each “3D object” must lose its “3D

properties” and be Exploded into the individual lines/arcs/curves that it is made up from.  The proce-

dure is as follows.

14. As your drawing may by now be a bit of a mess, select End Edit, and close the  

drawing (File > Close).  Choose the Open icon from the upper icon toolbar (or File > Open)

and load the drawing “Camera.dtd” from the Tutorials directory.  (This is the drawing as it was at

the end of step 10.)

15. Choose the Select All icon from the upper icon toolbar (or Edit > Select > All, or press 

CTRL + A on the keyboard).  The whole drawing should now be highlighted.

16. Choose the Explode icon from the upper icon toolbar (or Edit > Explode, or press 

CTRL + E on the keyboard).  In the Explode Settings dialog box, set the option Explode
fully to simple objects, then click Continue.  The drawing should not look any different, but you

will now be able to use Delete Any and Delete Part to remove unwanted lines.  (See fig f.)
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N.B.  When exploding there is a choice between Explode one level only and Explode fully to simple
objects.  Within a drawing there may be groups, paths, 3D objects, etc., in almost any combination, eg.,

you might have paths within 3D objects within groups, etc.  Explode one level only just explodes one

level of grouping, paths, “3D objects”, etc., at a time.  In the above example, the objects to be exploded

were “3D objects”.  If we had used Explode one level only, each “3D object” would have been explod-

ed into lines and paths (the paths being the rectangle and the trapezium parts).  If we had tried to use

Delete Any on a line that was still part of an unexploded path, eg., the hidden lower back line, the

whole path would have been deleted.  In other circumstances this might be very useful, but in this case

it was better to use Explode fully to simple objects so that all paths were fully exploded into their com-

ponent parts.
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TUTORIAL 22 - Exploding and Making Paths
Many objects (text, double line paths, filled shapes, etc.) are actually a collection of smaller objects

(lines, arcs, etc.).  In fact sometimes the smaller objects are themselves collections of even smaller

objects, eg., a dashed line is actually a collection of short lines.  Sometimes it is useful to “break” these

objects down into their component parts so that the individual parts may be edited.  

a b c

d e f

1. Start up 2D Design V2, or close any open drawings (File > Close).  Choose the New icon  

from the upper icon toolbar (or File > New).  For the purposes of this tutorial only, choose

Help > Restore Factory Defaults.

2. Choose the Linear text icon (LH toolbox).  Ensure that Grid Lock is on (RH toolbox).

At the prompt Locate start position for text, locate at position Abs (110, 150), then click the

LH mouse button.  The following dialog box will open.

Type in CAD then click the Settings button.  The following dialog box will open.
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Ensure that the Font is set to Arial Black, Font Style to Italic, Height to 75 and  Fill... to No Fill.
Click OK on both dialog boxes.   Your text should appear as in fig a.

3. Choose the Select icon (LH toolbox) and select the text by clicking on it.

4. Choose the Explode icon from the upper icon toolbar (or press CTRL + E on the   

keyboard.  The following dialog box will open.

Ensure that Explode one level only is ticked, then click Continue.

5. Select the letter A by clicking on it.

You will notice that only the individual letter is now selected, not the whole word, as the explosion

process has removed the text properties and has simplified the data by one level.  If the Explode fully
to simple objects option had been chosen it would be possible to select each line that makes up the let-

ter.  (This can still be achieved by selecting the letter and exploding it again.)

6. Click on the centre handle of the select box and drag the A to a position Rel (-30, -20), then click

to fix the position.

7. Select the letter D, drag it to a position Rel (-60, -50), then click to fix the position.  Your drawing

should appear as in fig b.
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8. Select the letter A again.  Click on the Start Edit button on the Property/Start Edit toolbox open in

the bottom RH corner of the screen.  Drag a select box around the two nodes at the bottom LH leg

of the A (see fig. c).  Click the Grid Lock icon (RH toolbox) to turn off grid lock.

9. Click on the left-most selected node with the RH mouse button.  Drag the leg of the A down until

it is level with the bottom of the D (see fig. d).  Click again, then click off the drawing to de-

select.

10. Choose the Delete Part icon (LH toolbox, click and hold on the Delete icon).

Delete all the lines in the overlapping areas (be sure to get even the small lines).  The draw-

ing should now appear as in fig e.

Having created a new shape it would be useful to combine the parts together so that they may be treat-

ed as one path so that they could, for example, be filled (as long as it is a closed path). This is different

to just grouping the objects as was done in Tutorial 19.  In grouping, all the objects remain completely

unchanged, but when making a path the objects may be re-ordered, or have their direction changed, in

order to form a continuous path where possible.

11. Choose the Select All icon from the upper icon toolbar (or Edit > Select > All, or press 

CTRL + A on the keyboard).  The whole drawing will be selected.

12. Choose the Make Path icon from the upper icon toolbar (or Edit > Make Path, or press 

CTRL + H on the keyboard.  At the warning prompt click Yes to continue.

13. With the object still selected, click on the Property button on the Property/Start Edit toolbox open

in the bottom RH corner of the screen.  The following dialog box will open. 

You will see that the object is now a single line path.  Click on the Fill button and in the Fill
Settings dialog box set the fill to be Solid and the colour to be Custom color Red.  Click OK to

close all dialog boxes.  Click off to de-select.  The drawing should now appear as in fig f.
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TUTORIAL 23 - Coordinate Data Entry
Some users occasionally wish to enter drawing data by typing in coordinates (although this is not the

recommended method for general drawing, as it can be tedious!).  At any time when the user is

prompted to locate a point (drawing a line, selecting an object, defining a zoom box, etc.), it is possible

to either type in coordinates or use the mouse.  Values may be input in Absolute coordinates (measured

from the drawing origin), Relative coordinates (measured from the last point located), or Polar coordi-

nates (the distance and angle from the last point located).  This tutorial deals with data input in this

manner by creating the drawing below using only coordinate input.  It also shows how individual enti-

ties may have their coordinates (and other properties) altered retrospectively.

a                                                                  

1. Start up 2D Design V2, or close any open drawings.  Choose the New icon  

from the upper icon toolbar (or File > New).  For the purposes of this tutorial only, choose

Help > Restore Factory Defaults.

2. Choose the Connected Lines icon (LH toolbox, click and hold on the Lines icon).

At the prompt Locate start point, move the cursor over the left hand coordinate entry box

(at the top of the screen next to the Abs button) and click the LH mouse button.  A text

entry cursor will appear in the box.  Type 120, then press TAB (usually above Caps Lock) on the

keyboard to move the cursor to the right coordinate entry box.  Type 90, then press Enter on the

keyboard (or click on the OK button with the mouse).  The drawing cursor should move to the

bottom LH corner of the shape, ie., the absolute coordinates (120, 90).  

3. With the mouse, click on the coordinate type button currently reading Abs, to change it to Rel. (If

you keep clicking on it, it will cycle around between Abs, Rel, and Pol).  Now type in the coordi-

nates (130, Tab, 0, Enter).  The base line will be drawn horizontal, 130mm length.

4. Change the coordinate type button to Pol by clicking on the button with the mouse, or by pressing

ALT+P on the keyboard.   Type in the coordinates (75.42, Tab, 45, Enter).  A line 75.42mm in

length will be drawn at an angle of 45 deg. 

5. Change the coordinate type button to Abs by clicking on the button with the mouse, or by pressing

ALT+A on the keyboard.  Type in the coordinates (250, Tab, 170, Enter).  Change the coordinate

type button to Rel by clicking on the button with the mouse, or by typing ALT+R.  Type in the

coordinates (0, Tab, 40, Enter), then (-80, Tab, 0, Enter).  Three more lines will be drawn.

6. Choose the Arc through two points, locating centre icon (LH toolbox, click and hold on

the Arcs icon).  At the prompt Locate first point, type in the coordinates (0, Tab, 0, Enter).

At the prompt Locate second point, type in the coordinates (-50, Tab, -50, Enter).  At the

prompt Locate centre, type in the coordinates (50, Tab, 0, Enter).  
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7. Choose the Single Lines icon (LH toolbox, click and hold on the Lines icon).

Type in the coordinates (0, Tab, 0, Enter), then (0, Tab, -70, Enter) to finish the drawing.

(See fig a.)

As you will have seen, entering a lot of data this way can be slow and requires great care.  However, it

can be very useful occasionally when a particular set of coordinates, or a certain dimension is required,

eg., a line of length 76.48mm, starting at coordinates (53.76, 73.98), at an angle of 123.67deg.
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TUTORIAL 24 - Closing Boundaries (for Boundary Fill and Contour)
The boundary fill and contour drawing routines rely on shapes having a closed boundary.  In each case,

once a shape has been located, the software proceeds to “trace” around the edge.  This only works

properly if the “tracing” routine finds a continuous boundary with no gaps or dead ends.  If a gap or

dead end is found, an “incorrect” contour may be drawn if using the contour routine, or if using the

boundary fill routine, an “incorrect” boundary may be found, or an error message may confirm that the

shape is Not a closed boundary.  In certain circumstances the boundary finding routine may appear to

go on forever (as it loops around an open shape), in which case pressing Esc will abort the routine.  It

may be obvious where the problem is, but sometimes, gaps may be too small to see, even on a maxi-

mum zoom.   (Remember that the system is normally working to an internal resolution of

0.0000001mm.)  Gaps usually occur where the drawing has not been fixed to a Grid or Step Lock, or

the Attach tool has not been used.  Below is an example of such a problem and how it may be over-

come.

a                                                b                                               c                     

1. Start up 2D Design V2, or close any open drawings (File > Close).  Choose the Open icon  

from the upper icon toolbar (or File > Open), and load the drawing “Boundary.dtd” from

the Tutorials directory.  (See fig a.)  For the purposes of this tutorial only, choose Help > Restore
Factory Defaults.

2. Choose the Contour icon (LH toolbox).

Click OK on the Contour Settings dialog box.  At the locate prompt, move the cursor to

position 1 approx., as shown in fig a, then click the LH mouse button.  A contour should be

drawn around the LH rectangle.

3. Choose the Boundary Fill icon (LH toolbox).

The Boundary Fill Settings dialog box will open.  Click on the Fill button to open the Fill
Settings dialog box.  Select Hatch then click OK to close all dialog boxes.  At the locate

prompt, move the cursor to position 2 approx., as shown in fig a, then click the LH mouse button.

To the question Any islands? answer No.  The LH rectangle will now be hatched.  (See fig b.)

4. Choose the Contour icon again (LH toolbox).

This time locate at position 3 approx., as shown in fig b.  A contour will be drawn inside

and outside of the rectangle (see fig c).

This contour is “incorrect”.  It has happened because somewhere there is a gap in the border and the

boundary finding routine has turned back on itself, causing the contour to “leak”  inside the rectangle.

5. Choose the Delete Last icon (RH toolbox) to delete the contour.
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6. Choose the Boundary Fill icon (LH toolbox).  Click OK on the Boundary Fill Settings
dialog box.  Locate at position 4 approx., as shown in fig b.  This time a message Not a
closed boundary will be displayed.  Note which lines are now coloured in pink (move the

message box out of the way if necessary), then click OK.

What has happened is that the boundary finding routine has “traced” around the inside of the shape, but

has stopped at the gap at one of the corners.  It is now necessary to find the gap and close it.   When

locating on the inside of a boundary, the located section will not turn pink at first, but all subsequent

sections will turn pink as they are found.  The routine will turn clockwise at all junctions until the

located section is found again, when it will also turn pink, completing the boundary.  If at any intersec-

tion a turn cannot be made, the boundary is incomplete.  In the example, the path is left along the bot-

tom, up along the LH edge, right along the top, stopping at the top RH corner.  Therefore that is where

the gap is. 

7. Choose the Zoom in icon (LH toolbox).  Turn the Grid Lock (RH toolbox) on.

Locate the zoom box as shown in fig b.  You should now clearly see 

the gap.

8. Choose the Zoom Last icon (RH toolbox).

9. Choose the Select icon (LH toolbox).

Select the RH line by locating at coordinates Abs (390, 160) approx.

10. From the Property/Start Edit toolbox (now showing in the bottom RH corner of the screen)

choose Start Edit.  The lines node points will be displayed.

11. Turn Attach on and Grid Lock off (RH toolbox).

12. Position the cursor over the top (green) node and click the LH mouse button.   Ensure that the

attach cursor is over the end of the RH end of the top line and click the LH mouse button again.

Finally, move the cursor well away from the drawing and click the LH mouse button twice to de-

select the line.  

The gap should now be closed.  You may like to re-try steps 4 and 6 to double check.

All boundary finding problems can be dealt with in a similar way - first find the gap, then close it.  

As you have seen, the “pinking in” of boundary lines whilst finding a fill boundary, can be a useful aid

to finding a gap.  If using the Contour routine, and an “incorrect” contour occurs, consider using the

Boundary Fill routine to help find the gap.  Although the position of the gap is fairly obvious in the

example given above, more complicated shapes may require more detective work. 

There are many ways to close gaps or eliminate dead ends, far too many to list.  For example, using the

editing mode, node points could be repositioned using Grid Lock or Attach to ensure accuracy, as we

have just seen, or lines/arcs could be extended (click the RH mouse button on a node) to ensure that

they fully overlap.  Any overlaps can be eliminated using Delete Part.
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TUTORIAL 25 - Setups and Customising the Software
During the course of this tutorial you will see how easy it is to reconfigure the user interface to suit

individual requirements or preferences.

1. Start up 2D Design V2, or close any open drawings (File > Close).  Choose the New icon  

from the upper icon toolbar (or File > New).  For the purposes of this tutorial only, choose

Help > Restore Factory Defaults.

2. Choose Setup > Load Setup.  Load the setup file “Year7.cfg” from the Setups directory.  The

screen display will change to a much simplified version with larger text, and many menu items

removed.  

3. To return to the original setup, load the setup file “Standard.cfg” from the Setups directory, or

choose Help > Restore Factory Defaults.

The process of creating and saving a user defined setup is very straightforward, as will be demonstrat-

ed by the following example.

4. Click and hold on the Circles icon on the LH toolbox to inspect the Circles toolbar.  Note that

there are many circle drawing option icons.

5. Choose Setup > Customise > Menu.  The following dialog box will open.

Select Draw in the first column, then Circles in the second column.  Click on the third circle

option, Two Points on Diameter, with the RH mouse button.  The option will turn grey (inactive).

Now grey out the rest of the circle options in the column (apart from the first two) by holding

down the RH mouse button and “running down” the column.  (To turn options back on again, re-

click on them with the RH mouse button.)  Finally click OK to close the dialog box.

6. Inspect the Circles toolbar again.  Note that there are now only two options.  Thus we have cus-

tomised the Circles menu.  All menu options in the software, not just the drawing options, can be

“turned off” in a similar way.
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7. Choose Setup > Customise > Drawing Area.  The following dialog box will open.

Click on the Backdrop button to open the Fill Settings dialog box.  Click on the Load Fill button

and load the fill “spaced out” from the Fills directory, then click OK to close all dialog boxes.

The drawing background fill will change accordingly.  (It can be useful to have a different back-

ground fill or colour for each setup, especially in education, so that it is easy to recognise the

setup at a glance.)

8. Choose Setup > Drawing > Layout.  (This is the same as choosing the Layout icon from 

the upper icon toolbar).  Set to Standard size ISO A3, and select Portrait.  Click OK to close the

dialog box.  Note that the drawing area is now Portrait.

9. Choose Setup > Customise > Information Area.  The following dialog box will open.

Set all the text heights to 20, deselect all the Coordinate Entry options, all the Coordinate Display
options, and the Attributes Display option Current Layer.  Click OK.  Note the effect on the

screen layout.  
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In a similar way, it is possible to change all the settings under the Setup > Customise sub-menus, eg., to

make the toolbox icons larger, use Setup > Customise > Toolbox.  It is also possible to change the

scale, current units, etc., using the Setup > Drawing options, and the Tools and Output route, etc., for

the various plotting devices using Setup > CNC Devices.

10. Choose Setup > Save Setup.  In the Save Setup Options dialog box leave the Include > Save Setup
option in saved setup option set, and click OK.  (If this option is not ticked, the Save setup option

will not be included when the setup is loaded later.  Thus it will be difficult to overwrite this

setup from itself.  This may be of particular interest to educational users.)  Give the setup a name

of “Temp”, then click on Save to save it.

Whenever this setup “Temp” is loaded using Setup > Load Setup, all the values set in the Setup menu

will be restored.  

When a drawing is saved, all the settings available under Setup > Drawing (and the current CNC

device settings if Set for CNC device is chosen in Setup > Drawing > Layout), together with all the

current settings such as circle radius, text height, etc., are saved with the drawing.  When the drawing

is loaded normally using File > Open, all the settings saved with the drawing are restored.  If you wish

to load a drawing without changing the current settings, use File > Add.
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